Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-17 of 28 Results
  1. Utility ATV repair, maintenance, troubleshooting
    Been riding my MP all spring and summer with 0 issues. This weekend I went into a bit of skag. I put it in low and hit the happy handle. About 20 ft in my quad lost all engine power like it ran out of fuel. I let go of the throttle and it continued to run. I then attempted to get out of the skag...
  2. General Snowmobile Discussion
    I have a 2005 Z570 I purchased in 2018. Lack of snow in NE plus 2 babies, I wasn't able to ride it until last season. Fuel consumption is terrible to say the least. Used a full tank on a 33 mile run. Had a local shop look at it at the end of last season and they told me the clutch needed to be...
  3. Snowmobile repair/service manuals
    Need help figuring out what could be causing my sled not to run right, so far i have put new plugs in, tested for spark and have spark on all three cylinders. spark plug wires are good, ive taken the carbs apart twice and cleaned them and all the jets, its getting fuel no problem. Put new intake...
  4. Arctic Cat Snowmobiles
    02 zl 600 was running great for 250 miles of trail riding. We got three feet of powder and played around in it for about 45 mins. Last lap in deep snow the sled immediately bogged, sounded like I hit kill switch but i didn’t. Fired back up immediately after, and it bogged once more within 30...
  5. CrossFire/CF/CFR 06-11
    Okay first off I am new to this forum. You guys have helped me with a lot of issues. I am having issues with my crossfire not starting. The issue I have is it will not start when cold. If I put gas down the heads the sled will fire and run all day no problem. Shut it off and it’ll fire back up...
  6. Proclimb M/Ascender/Alpha One 2012+
    I have a 2012 M800 which last year started acting up, after firing up the snowmobile it would run for about 10 minutes then die, and be completely dead until it cooled down for a couple of hours or so. this only got worse, and changing the stator seemed to help, now it would run for 1hour +...
  7. General ATV Discussion
    Hello. I have a 2009 ARCTIC CAT 366 4X4. It has worked fine until now. I had a little bit of trouble starting it after the winter. But now it has stopped and will not start again. I tried change the plug and that worked about a block. So now I’m guessing it’s not getting enough fuel. Do anyone...
  8. General Snowmobile Discussion
    I have a 93 ZR that I am fixing as a highschool project and I need to get the gas tank off because the line from the tank to the fuel filter is clogged and I need to replace the part from the tank, how do I take off the gas tank is it from under the tunnel, do I need to take off seat too?
  9. Utility ATV repair, maintenance, troubleshooting
    I have a "new to me" TRV 1000 and love it, however every once in a while it wont rev up and idles along at 20 to 30 mpg it sounds like it is missing and small back fires. I found if I stop turn it off and restart it she runs great again. Dealer is not sure and need to test it when it is not...
  10. Firecat/Sabercat
    I was just wondering what the compression range for a stock 06 F7 efi should be. I have heard rumors that they should run close to 150 psi? Mine is currently at 120 pto and 118 mag and has about 6400 miles. I was thinking of doing the top end but I would like to find out where it should be to...
  11. M Series/Mountain Cat Pre 2011
    I have a 2002 Mountain Cat 600EFI, I got it last season and it ran great. at the very end of last season the sled died on me in mid powder turn. The sled would turn on but as soon as you put enough throttle on the machine to move it, it would die again. after a couple hours of this i got it to...
  12. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    [Fixed] Air in Fuel line help! 1997 Arctic Cat Jag Deluxe 431cc Hello, I have a 1997 Arctic Cat Jag Deluxe, two years ago it ran great with no problems at all. Then the year after that (last year) we didn't get enough snow so it didn't get run at all. Now this year I went to start it but no...
  13. General Snowmobile Discussion
    Hi all, Just bought a 1992 Panther Deluxe, drove 350 miles with it in the truck bed, used it to drive 11 miles home. In that time we started it 4 or 5 times -- started no problem. And it started just fine in the guy's shop when we bought it. The next day we pulled & pulled &...
  14. General ATV Discussion
    Trouble starting often. Sometimes starts and then sound "bogged down" and won't drive without stalling out. "EFI" flashes on display when it doesn't start most of the time. Increasing in frequency. When it does start without the error, it seems to run just fine, so it is intermittent. I'm...
  15. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    I just rebuilt the engine the other day and everything went smooth. I did a little bit of "test riding" today and the only issue i had is the bad gas occasionally causing a sputter but nothing serious. I had siphoned most of the bad gas out and swung by the gas station and put a fresh tank in...
  16. Vintage 1992 & Older
    We got some snow here in Nebraska, so I pulled out the El Tigre! I rode it for a little while, nothing too insane. Multiple times I shut it off for a few minutes up to a half hour, and it started up with a half-pull each time. One time, however, it just wouldn't start. I tried it multiple times...
  17. Firecat/Sabercat
    I just got an 05 F6 EFI snopro and was woundering if i should use preimium fuel or unleaded :huh: thanks for any help
1-17 of 28 Results
Top