Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-17 of 17 Results
  1. Panther/Pantera/T570/Touring
    Hello all, I'm new to the forum hoping to find a little help. I believe I'm in the correct thread but please suggest if it should be moved. Thanks! The Sled - 2002 panther 570 fanner I'll start by saying that I am by no means a sled expert or a 2-stroke expert but I have done a fair amount of...
  2. Utility ATV repair, maintenance, troubleshooting
    Hi all, new to this forum here but have been using the search bar but no real like in finding anything to help me out here. Bought a cheap 2006 arctic cat 400 VP model a week or so ago and seemed to be running fine since. Yesterday I went to take it out and I noticed it took a real long time to...
  3. Utility ATV repair, maintenance, troubleshooting
    So you see a lot of posts on here about limp mode. Well let's break limp mode down for people who may not be mechanically saavy. Your ATV may be equipped with a fail safe that we call "limp mode". What happens is that your machine has thrown a semi-serious to a serious code through your ecu/cdi...
  4. M Series/Mountain Cat Pre 2011
    sled sputters out right or start takes a second once the rpms kick it in the thing hauls like a tractor until it tops out at 80 -90 kmh nowhere near normal top speed, sled has new plugs and belt riding a lot in deep powder and sled doesn't get stored in a heated shed, thinking ice in the air box...
  5. General Snowmobile Discussion
    I need a snowmobile expert--- heres the problem.=== its a 1998 Arctic cat 600 powder sport. if you hang it, it runs like a champ. clutches are great. its fuel injected. as soon as its on the ground, it will idle great. track kick in right about 4500 RPM's as you accelerate, it goes ok but will...
  6. Vintage 1992 & Older
    Hello everyone. I have a few questions regarding the one sled I have that isn't runing right (my 80' AC Lynx 2000/t). I haven't had time to tinker much with it, since it has been in NY for a while and I live in MA (parents have land in NY keep it indoors there). Now that my father and I are...
  7. SnoPro Chassis 08-14 600/13-14 500
    i bought the'11 sno pro from a dealer in nome, ak in april of '10 i have 1038 miles on the cat i live in very cold isolated town called kotzebue and i had my cat parked for little over a month "the coldest month" so when it warmed up a little i started it up and it ran like a beast for just...
  8. Panther/Pantera/T570/Touring
    I am trying to sell my sled and had a guy come look at my 1997 Arctic Cat Pantera 580 EFI today. Started right up with electric start but then would bog if given any throttle. This had happened once before and I put new plugs in and it solved the problem. NGK BR9ES. Did the same thing today but...
  9. Firecat/Sabercat
    2006 f7efi with 1300 miles. its missing and sputtering at high rpm and as no throttle response. power valves have been cleaned, and was not the problem injector cleaner has been added. skidoo had jaws can that was removed and original installed still havent fixed problem. Any help would be...
  10. General Snowmobile Discussion
    i think i have this posted in the right place im out of other ideas hopefully somebody out their knows a lot more than i do lol i have a 93 ext 550 carb. it will sit and idle all day long but if you try to mash the throttle it bogs bad will not rev up enough to even engage the clutch however if...
  11. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    Does anyone know what the correct pilot jet setting is for a 2000 z 440? Also any ideas on the idle screw settings? The sled runs good but will bog (what seems only when my girl friend rides it) every once in a while when cruising down the trail but more so in the tight trails. Any ideas would...
  12. Firecat/Sabercat
    I've had an ongoing problem with my 05 efi 700, that no one seems able to figure out, or they don't seem interested in. been to the shop 3 times. i was wondering if my snowmachine would run right or what it'd act like if the case seals were out.
  13. Firecat/Sabercat
    Hi I have cleaned power valves, servo is working, checked smart valves, checked injectors. air box clean and dry. Plugs are good look like good burn. The only thing is the secondary it has a brand new primary. Any Ideas would be great. It seems to me like it does it more when the motor is warmer...
  14. Vintage 1992 & Older
    hello, I got an 1980 el tigre 6000 liquid cooled. When i start it up it runs fine no bogging for about 5 min of riding but when it warms up it starts bogging after that the only way i can get it moving is to let it idle for 30 sec or so and open the throttle all the way, when its full throttle...
  15. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    I recently purchased a brand new, mint 1999 Arctic Cat Z.R. 500 and modified it a bit in multiple ways (view signature for referance). I recently encountered some some-what severe engine damage. The throttle had been "bogging" when-ever I tapped it, making it impossible to ride. Along with this...
  16. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    i have a 2000 zr500efi i think i need an ecu because of a bog problem, tss is un hooked, tps is in spec, stator is new and tests good, coil has been swapped out from another sled that curretly runs fine. once the rpms get about 7-8 is falls on its face and acts like it wants to shut off. i have...
  17. Sled Mods & Tech-Tips
    I have a 1999 zl500. It starts just fine and idles no problem. When I give it throttle, sometimes it'll run just fine and sometimes it will bog down. If it starts to bo and I let off the throttle, I can usually save it, but if I just hold the throttle it kills right out. Is it getting too...
1-17 of 17 Results
Top