Arctic Chat : Arctic Cat Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-10 of 11 Results
  1. Utility ATV repair, maintenance, troubleshooting
    Hey guys sorry if this is a repeat post but I haven't seen another covering this issue but I have just rebuilt the top end of a 2014 550 prowler xt and felt like I have everything perfect but when I go to crank the prowler it will spin over just fine but will not start but then after a few times...
  2. Utility ATV repair, maintenance, troubleshooting
    So I've recently picked up a 1999 arctic cat 500 4x4 which I thought was in decent running condition. Was able to take it for a test ride and seem to idle and run well at the time. First night out after about 20 minutes it started to back fire a decent amount when ever I let off the throttle and...
  3. Utility ATV repair, maintenance, troubleshooting
    Kids had 2002 400 ATV out yesterday. Sputtered,backfired, and now has no power. It was hot, but fan was running and no overtemp light. Any ideas what’s going on?
  4. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    My 2000 ZR 600 EFI with 1900 miles is not running right. Last year it back-fired, lost power, and died. Later it would seem fine. It left me stranded twice. A local repair shop replaced the stator and it seemed okay for a while. Today (2/2/13) it started doing the same thing. Any advice...
  5. Utility ATV repair, maintenance, troubleshooting
    Any advice is much appreciated. My dad and I have an '03 attic cat 500 and it had been sitting up for almost 2 years so I did the basics...oil and oil filter change, new air filter, new spark plug, drained the old gas, and change the anti-freeze but it would not start still. So I cleaned the...
  6. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    My Tcat 1000 ran great for a couple miles then started backfiring and bogging. I pulled the spark caps off one by one to see if it was any particular cylinder that wasn't firing - couldn't locate a bad cylinder. I thought it might be overheating so I dumped a bunch of snow in the engine...
  7. Firecat/Sabercat
    so after having issues with loosing headlights and grips ect last winter i bought a new stator and installed it this past weekend on my 2004 snow pro with a 2004 f6 efi swap after getting everything back together i go to start it and as always second pull it fires and then dies instantly. This...
  8. Utility ATV repair, maintenance, troubleshooting
    Hi I just got a 98 Bear Cat 454 4x4 from a friend it was not running when i got. We had it in some mud it died never started again and sat for about 2 yrs. Soon as i got it I emptied the gas tank put new gas changed the oil. I pulled the carb off took it apart and cleaned it good i have plenty...
  9. Utility ATV repair, maintenance, troubleshooting
    I own an 04 Arctic Cat 650 V2, the thing did not want to idle, and it has always started quite hard. The throttle would need to be slightly feathered to start. Pre tear down indicated an air leak somewhere since the quad after the removal of the cover that secured the air filter box would idle...
  10. Z/ZL/ZR/ZRT/T-Cat/EXT/JAG/Cougar
    Hey I just bought my 2000 tcat with 4800miles on it last weekend. Checked it out and it seemed like it was good to go so I took it out for its maiden voyage an we ran into a couple issues. The first one was with the coolant system. It never over heated and I know this because the dummy light...
1-10 of 11 Results
Top