Odometer trouble 02 ZL SS 600 - ArcticChat.com - Arctic Cat Forum
 6Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 23 Old 12-08-2017, 05:30 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Dec 2017
Posts: 15
Thanks: 5
Thanked 0 Times in 0 Posts
Odometer trouble 02 ZL SS 600

Hello,
Towards the end of last years snowmobile season the odometer on my 2002 ZL SS 600 arctic cat quit working. I haven't noticed any other problems with it other than this. I have been told that it way be the jack shaft bearings going out or have already went out. Where do I start to trouble shoot with this issue and what are opinions on what this may be that is typical of these sleds?
Thanks in advance for any information.
5449402 is offline  
Sponsored Links
Advertisement
 
post #2 of 23 Old 12-08-2017, 05:40 PM
Senior Member
 
tcat446's Avatar
 
Senior Member
Join Date: Jul 2006
Location: Ripley, New York
Posts: 9,689
Thanks: 49
Thanked 721 Times in 698 Posts
Sled: 2000 thundercat 1996 ZRT 800 AGLT/136"
10-11 Mileage: 1249
09-10 Mileage: 1200
07-08 Mileage: 650 - 2 thaws
06-07 Mileage: 1100
ATV: Arctic Cat 500/ SuzukiQuadzilla 500-sold
Check #9. Take it off and see if the bearing is physically shot or if the square key way is sheared off. That would be a good starting point.
Attached Thumbnails
Click image for larger version

Name:	11.gif
Views:	101
Size:	55.9 KB
ID:	320874  
5449402 likes this.



Life is not a bowl of cherries, it's more like a jar of jalapenos, what you do today can burn your ass tomorrow !!!







https://www.arcticchat.com/forum/pinn...to-96-zrt.html
Crossfire skid into a 96 ZRT

https://www.arcticchat.com/forum/z-zl...t=zrt+800+aglt
ZRT 800 AGLT
tcat446 is offline  
The Following User Says Thank You to tcat446 For This Useful Post:
5449402 (12-08-2017)
post #3 of 23 Old 12-08-2017, 05:44 PM
Senior Member
 
Senior Member
Join Date: Jun 2016
Location: Minnesota
Posts: 506
Thanks: 0
Thanked 50 Times in 48 Posts
pull the driven clutch and below that is the gearbox. There is a spring steel shaft that breaks when the bearing goes out. You will need to pull the skid out and open the chaincase as you will have to remove the drive shaft from the sled in order to replace the bearing. Do yourself a favor and replace both. Two to three hour job. Depending how many beers. Good luck.
5449402 likes this.
ZR6000 is offline  
The Following User Says Thank You to ZR6000 For This Useful Post:
5449402 (12-08-2017)
Sponsored Links
Advertisement
 
post #4 of 23 Old 12-08-2017, 06:03 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Dec 2017
Posts: 15
Thanks: 5
Thanked 0 Times in 0 Posts
ZR 6000 is there anywhere that I can view Diagrams of what you are exactly targeting like tcat446 did above? So this is most likely a bearing problem that I will have to dig into the chaincase to fix rather than any type of cable that runs to the odometer because I would hate to tear the sled apart if it were just to be the cable to the odometer rusted off or something of that nature. Thanks.
5449402 is offline  
post #5 of 23 Old 12-08-2017, 07:11 PM
Senior Member
 
tcat446's Avatar
 
Senior Member
Join Date: Jul 2006
Location: Ripley, New York
Posts: 9,689
Thanks: 49
Thanked 721 Times in 698 Posts
Sled: 2000 thundercat 1996 ZRT 800 AGLT/136"
10-11 Mileage: 1249
09-10 Mileage: 1200
07-08 Mileage: 650 - 2 thaws
06-07 Mileage: 1100
ATV: Arctic Cat 500/ SuzukiQuadzilla 500-sold
I have a 96 Cougar in the shop right now that had a broken speedo cable. Ordered a new one and all is fine.

Take the adapter off and see if the bearing looks good. As stated earlier, also look at the key way or as ZR6000 stated "steel shaft" to see if its broken. 9 out of 10 times the key way or shaft breaks when the bearing is bad. I would check this first as its easier to do. If not then investigate further.
His referring to "gear box" meaning the speedo drive adapter as I had already stated. It is the one pictured with the 3 nuts and bolts holding it on.

Try looking stuff up on this link:
Alpha Sports - Arctic Cat Snowmobile Catalog
5449402 likes this.



Life is not a bowl of cherries, it's more like a jar of jalapenos, what you do today can burn your ass tomorrow !!!







https://www.arcticchat.com/forum/pinn...to-96-zrt.html
Crossfire skid into a 96 ZRT

https://www.arcticchat.com/forum/z-zl...t=zrt+800+aglt
ZRT 800 AGLT
tcat446 is offline  
The Following User Says Thank You to tcat446 For This Useful Post:
5449402 (12-08-2017)
post #6 of 23 Old 12-09-2017, 06:21 AM
Administrator
 
C-note's Avatar
ArcticChat.com Admin
 
Administrator
Join Date: Dec 2005
Location: Mi.
Posts: 19,731
Thanks: 2,008
Thanked 1,063 Times in 934 Posts
07-08 Mileage: 2 few
06-07 Mileage: ^^^^
I see no mentioning of the SPEEDOMETER no longer able to operate as well, just the ODOMETER itself, and that you hadn't "noticed any other problems" elsewhere.... Does your speedometer needle still work?

Who, me?! Don't listen to me.... (I don't know anything, evidently...)

Quote:
If it's cnote approved it will work good
Quote:
Originally Posted by DonoBBD View Post
That is freeking sick man........
Don
0637-185: '99 Sno-Pro APV (guide and button) update kit p/n...
0637-186: '99 Sno-Pro APV superseded valve inserts update kit p/n...
https://www.arcticchat.com/forum/z-z...tml?highlight=

http://www.randakksblog.com/more-on-...fear-the-corn/

"Arctic Chat is not affiliated with Arctic Cat Inc. in any way, shape or form. We are an enthusiast site run by fans."

(Are you experiencing issues with your local dealer? Feel free to call Cat Consumer Complaint @ 218-681-8558)
C-note is offline  
post #7 of 23 Old 12-09-2017, 06:38 AM
Senior Member
 
tcat446's Avatar
 
Senior Member
Join Date: Jul 2006
Location: Ripley, New York
Posts: 9,689
Thanks: 49
Thanked 721 Times in 698 Posts
Sled: 2000 thundercat 1996 ZRT 800 AGLT/136"
10-11 Mileage: 1249
09-10 Mileage: 1200
07-08 Mileage: 650 - 2 thaws
06-07 Mileage: 1100
ATV: Arctic Cat 500/ SuzukiQuadzilla 500-sold
Good point Rusty. Might just be the speedo is bad. Had one that was froze up once, and thought it was the bearing. He just bought another speedo. I should of realized that.



Life is not a bowl of cherries, it's more like a jar of jalapenos, what you do today can burn your ass tomorrow !!!







https://www.arcticchat.com/forum/pinn...to-96-zrt.html
Crossfire skid into a 96 ZRT

https://www.arcticchat.com/forum/z-zl...t=zrt+800+aglt
ZRT 800 AGLT
tcat446 is offline  
The Following User Says Thank You to tcat446 For This Useful Post:
C-note (12-10-2017)
post #8 of 23 Old 12-09-2017, 06:44 AM
Senior Member
 
Senior Member
Join Date: Jul 2015
Location: North Bay, Ontario
Posts: 174
Thanks: 6
Thanked 6 Times in 6 Posts
Sled: 1998 ZL500 & 1996 MXZ 583
If you're talking about the speedo there are a few things to try:
1) unscrew the speedo cable, put the end of the cable in a drill and spin it while looking at the speedo. Make sure the drill is spinning it the right direction. If the speed doesn't move it's either the cable or the speedo itself.
2) remove the speedo adapter, the little silver thing underneath the secondary clutch where the cable attaches to. If the little silver key isn't broken that goes from the driveshaft to the adapter it could be a few thing. Take the key and spin it in the adapter. If the other side spins (where the cable attaches) the adapter works. If it doesn't spin you need a new speedo adapter.
3) check bearings on the driveshaft if there is any play in the driveshaft usually the bearings need to be replaced. This also causes the key in the adapter/driveshaft to break.

I would start there and get back to us
5449402 likes this.

Last edited by NorthernCat93; 12-09-2017 at 06:47 AM.
NorthernCat93 is offline  
The Following User Says Thank You to NorthernCat93 For This Useful Post:
5449402 (12-11-2017)
post #9 of 23 Old 12-09-2017, 07:59 AM
Team ArcticChat
 
Bob P's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Jan 2010
Location: Grand Rapids, Michigan
Posts: 1,047
Thanks: 57
Thanked 62 Times in 51 Posts
Garage
Sled: 02 ZL600 EFI ESR 94 ZR 580
Quote:
Originally Posted by C-note View Post
I see no mentioning of the SPEEDOMETER no longer able to operate as well, just the ODOMETER itself, and that you hadn't "noticed any other problems" elsewhere.... Does your speedometer needle still work?
That was my first question.
C-note likes this.
Bob P is offline  
post #10 of 23 Old 12-09-2017, 11:09 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Dec 2017
Posts: 15
Thanks: 5
Thanked 0 Times in 0 Posts
It is my speedometer as well as my odometer that quit working. So basically the whole right cluster on the dash. The left cluster that reads the RPMs still works fine. I have done more research into it by talking to some repair shops and they seem to think it is the drive line bearings that need replacing. I am hoping that is not the case because supposedly the suspension must be taken out in order to get to this problem along with a lot of other labor.

Last edited by 5449402; 12-09-2017 at 11:13 PM. Reason: More info added
5449402 is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed odometer Jkpaben Prowler Repair Forum 2 05-09-2017 06:04 AM
Odometer gained 2000 miles over night StevensPoint 4 Strokes 10 01-13-2017 04:21 PM
Need help trouble shooting please rbiman19 Utility ATV repair and maintenance & Troubleshooting 0 07-25-2016 05:17 AM
Speedometer works, odometer doesn't. HELP!! arcticchiller General Snowmobile Discussion 1 01-31-2016 12:35 PM
Having trouble locating parts Bennett131 F Chassis 2007- ?? 5 01-24-2016 10:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome