Main display error - ArcticChat.com - Arctic Cat Forum
New Member Introduction Only!!!! If you are new to the site please introduce yourself in here. You will find that our community is very friendly. If you have questions on how to use the site this is the place to ask! If you are having difficult starting a new thread in this section, this convenient link should start a new thread for you. Simply Click Here. However this is NOT a how do I fix this or what is wrong thread!!!! please use the correct forums for that.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-16-2019, 01:16 AM Thread Starter
Junior Member
 
Junior Member
Join Date: May 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Question Main display error

Hello guys. I'm new here , i want to say hello everyone . I would ask you one question , I have an 2009 Arctic Cat 1000 H2 EFI TRV Cruiser 4x4 and a few days ago it start to show on main display , oil indicator with some indicator like a lamp fluctuating , and the speed indicator make constantly movements around bord. I saw , when i'm trying to activate 4wd , it disappear , when turn back 2wd , appears again.

Does any know what's this error?

Appreciate ,
Cristian.
cristeacristian is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 05-16-2019, 10:15 AM
Administrator
 
doorfx's Avatar
ArcticChat.com Admin
 
Administrator
Join Date: Jan 2011
Location: Calgary AB.
Posts: 34,656
Thanks: 3,632
Thanked 3,007 Times in 2,779 Posts
Garage
ATV: 13 700 XT trv
2010 Mileage: 800
2007 Mileage: 800
2006 Mileage: 800
Welcome to the site!
Please post your questions in atv forums. This is not the place thx

2013 700 XT TRV EPS :
28" Bighorns on bed linered 08 Prowler rims , Wireless winch remote, 3000LB. Warn winch, Heated front and rear grips, Cat relay wiring harness for accessories, LED light bar, 08 650 trv LTD rear box, Heated rear seat, Elka stage 3 shocks all 4 corners, Aftermarket A-arm bushings, aftermarket sway bar bushings(prototype), Deluxe brush guard bumpers front and rear, Red anodized Hause fairlead, beverage opener winch hook, Synthetic winch rope, RTR motor mount bushings, Dynojet PC5 programmer, Dynojet Autotune, [/B]

07 500 Gone but not forgotten;
Dynojet/142m/45p/3rd/3turns--Clipped and drilled--Unifilter--Easy adjust PMS--L.C.V. mod--AC Swaybar--Exhaust mod--2"Snorkels--Sanny shock bushings-- Airdam stage 1--PSC phase 2--21/ 23gr rollers--Dalton yellow spring--.7mm shim--Sanny Steerlites--RTR Flex Bracket--2 up seat / pegs--Tach--AC handguards--28" Outlaw mst's--Skull tailight--Skull shifter--Self Resetting Breakers--1" Wheel spacers--Customcncparts Steering Damper--AC deluxe handwarmers--6000k HID'S hi/lo--AC Deluxe Bumpers--Inline Fuel Filter-- O2 sensor \AFR guage--Black Magic Full Stainless Exhaust System--Wireless Winch Remote--29.5 Outlaws--Fox Podium X Rear Shocks--




It's mind over matter,If you don't mind,
It just doesn't matter

No Boost No Bottle
just balls and throttle
doorfx is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > New User & Site Help Area > New Member Introduction Only!!!!

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 550/700 Error Codes Fairmont79 Prowler 1 09-05-2018 09:40 AM
2008 Prowler XT 650 Blows Main Fuse When In Gear baskervi Prowler 1 11-30-2017 11:04 PM
2009 Thundercat display blink(but there is a twist) Justinleggett General ATV Discussion 5 07-22-2017 06:38 PM
2004 500 cc 4 wheeler display issues Danbeck New Member Introduction Only!!!! 0 10-30-2016 10:18 PM
2006 700 EFI Main Fuse keeps blowing Bman409 Utility ATV repair and maintenance & Troubleshooting 12 07-02-2016 03:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome