2010 f600 too much oil and bog - ArcticChat.com - Arctic Cat Forum
Arcticchat.com Site Help and Support This section is for Forum / Account issues only. No Arctic Cat discussions.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-17-2019, 12:55 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Feb 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2015 SNOPRO F600, 2010 SNOPROF600, 2015
2010 f600 too much oil and bog

Hi I have a 2010 f600, it seems to use too much oil and it has a bog at mid throttle,it will clear if you play with the throttle, i have good compression just changed the rings, new oil pump, new computer, new exhaust temp sensor.
Please help this thing is costing too much to find a fix.
jimbosma is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > New User & Site Help Area > Arcticchat.com Site Help and Support

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome