Crossfire 800 -11 Ecu 17 code - ArcticChat.com - Arctic Cat Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-18-2019, 04:59 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Mar 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Crossfire 800 -11 Ecu 17 code

Hi

I ran sled deep to left side almost tipping over, then suddenly it didnt respond when i accelerated, then backfire once just after. Then i got ecu 17 code. Is like the error occurred when I drove deep to the side.

Message is there all the time. Switch to new sensor today, but no difference, message not gone. Wondering if anyone can explain to me how to set a resistor so I will avoid this problem forever. The sled still goes well, but not as crunchy, a little unclean at low rpm. Reduced ignition? more fuel? It has pc5, speedwerx pipe, y-pipe. I also tried to disconnect the pc5 but no difference. if problem dont go away with new sensor , resistor would not help either i guess. Maybe problem is in ecu cable =( I heard it can be

Will soon be on a mountain trip with friends so have a little hurry

grateful for help

Last edited by vintersaga; 03-18-2019 at 05:36 PM.
vintersaga is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-24-2019, 07:54 AM
Senior Member
 
crash74's Avatar
 
Senior Member
Join Date: Jul 2011
Location: Brainerd, MN
Posts: 477
Thanks: 1
Thanked 25 Times in 25 Posts
Garage
Sled: 02 ZR 600 CCE
10-11 Mileage: 300ish 93 700 wildcat
09-10 Mileage: 150 93 wildcat
08-09 Mileage: 400ish
07-08 Mileage: 1600
06-07 Mileage: 800
If you replaced the temp sensor and it's still flashing ECU 17 then you may have a bad temp sensor again. With ECU 17 flashing you will use 30% more fuel. Hopefully you didn't buy the new one from cat ($135). If you have a NAPA auto parts nearby then get one from them, part# 2-31015 ($65ish). That sensor is the same one GM uses in some of their trucks, plug and play.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190324-075053_1553431957314.png
Views:	3
Size:	502.3 KB
ID:	347043  

When life hands you lemons, don't make lemonade.
Shove em down the throats of your enemies!!!
crash74 is offline  
The Following User Says Thank You to crash74 For This Useful Post:
favoritos (03-24-2019)
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 crossfire 1000 ecu code 7 Schilde143 CrossFire 136-141 1 01-21-2019 06:04 PM
2010 crossfire 600 ecu code 17 Jordan_kennedy91 CrossFire 136-141 1 01-07-2019 12:09 PM
2016 mp 700 misfire, code and random shuts off dutchie88 General ATV Discussion 6 04-14-2018 09:31 PM
2016 8000 hesitation. Flying Dutchman Procross 2012-? 27 02-08-2017 05:08 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome