ZR580 idle question - ArcticChat.com - Arctic Cat Forum

Reply
Old 08-23-2016, 09:23 PM   #1
Junior Member
 
Junior Member
Join Date: Aug 2016
Location: North Dakota
Thanks: 0
Thanked 0 Times in 0 Posts
ZR580 idle question

I just got a 97 ZR 580 EFI the other day. It starts fine but after a minute it idles up to about 3800. It also is not engaging or moving. I haven't looked at it much yet, but the coolant is also gone. I added some and it is gone after running for a couple times. Wondering where to start with it. Thanks guys. Also it is 90 out if that affects anything.
Arcticmatt3 is offline   Reply With Quote
Remove Ads
Old 08-23-2016, 09:27 PM   #2
Junior Member
 
Junior Member
Join Date: Aug 2016
Location: North Dakota
Thanks: 0
Thanked 0 Times in 0 Posts
Also if you hit the throttle it will bog down eventually to the point of quiting. Even playing with the throttle it will bog down badly
Arcticmatt3 is offline   Reply With Quote
Old 08-24-2016, 12:58 PM   #3
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Blairmorganville
Thanks: 4
Thanked 92 Times in 92 Posts
Sled: 94 ZR 580
Where is the coolant going???? Don't run it without coolant.
__________________
[
94ZR580 is offline   Reply With Quote
Old 08-24-2016, 01:05 PM   #4
Senior Member
 
tcat446's Avatar
 
Senior Member
Join Date: Jul 2006
Location: Ripley, New York
Thanks: 43
Thanked 620 Times in 598 Posts
Sled: 2000 thundercat 1996 ZRT 800 AGLT/136"
10-11 Mileage: 1249
09-10 Mileage: 1200
07-08 Mileage: 650 - 2 thaws
06-07 Mileage: 1100
ATV: Arctic Cat 500/ SuzukiQuadzilla 500-sold
Not into the EFI's but check and see if you spray carb cleaner around EFI throttle body boots if the sled revs up. It may have a cracked boot. Spray around the back of the primary clutch and see also. It may have a bad crank seal. I'm sure the pros will chime in soon.

Is there any antifreeze on the floor?
__________________


Life is not a bowl of cherries, it's more like a jar of jalapenos, what you do today can burn your ass tomorrow !!!







http://www.arcticchat.com/forum/pinn...to-96-zrt.html
Crossfire skid into a 96 ZRT

http://www.arcticchat.com/forum/z-zl...t=zrt+800+aglt
ZRT 800 AGLT
tcat446 is offline   Reply With Quote
Old 08-24-2016, 09:18 PM   #5
Junior Member
 
Junior Member
Join Date: Aug 2016
Location: North Dakota
Thanks: 0
Thanked 0 Times in 0 Posts
I haven't done the carb cleaner test yet. I was thinking that might be it. I have moved it 3 times since I filled the coolant so haven't noticed a leak
Arcticmatt3 is offline   Reply With Quote
Old 08-24-2016, 10:40 PM   #6
Senior Member
 
tcat446's Avatar
 
Senior Member
Join Date: Jul 2006
Location: Ripley, New York
Thanks: 43
Thanked 620 Times in 598 Posts
Sled: 2000 thundercat 1996 ZRT 800 AGLT/136"
10-11 Mileage: 1249
09-10 Mileage: 1200
07-08 Mileage: 650 - 2 thaws
06-07 Mileage: 1100
ATV: Arctic Cat 500/ SuzukiQuadzilla 500-sold
Some places to check for a leak would be: damaged heat exchanger, water pump leaking, coolant hose rubbed thru under recoil starter on frame, rate but possible, bad o-rings in head (are pistons silver on the top?) or a possible base gasket. Just a few things to look for.
__________________


Life is not a bowl of cherries, it's more like a jar of jalapenos, what you do today can burn your ass tomorrow !!!







http://www.arcticchat.com/forum/pinn...to-96-zrt.html
Crossfire skid into a 96 ZRT

http://www.arcticchat.com/forum/z-zl...t=zrt+800+aglt
ZRT 800 AGLT
tcat446 is offline   Reply With Quote
Old 08-26-2016, 05:21 PM   #7
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Blairmorganville
Thanks: 4
Thanked 92 Times in 92 Posts
Sled: 94 ZR 580
If coolant is disappearing it can either be leaking outside, which you should be able to see, or into the engine where it will make huge quantities of white smoke and/or ruin the crank and con-rod bearings.
__________________
[
94ZR580 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help - Low Idle Speed - '99 Pantera 580 EFI RCP42 Arctic Cat Snowmobiles 0 02-27-2016 01:24 PM
Shock question and a seat question 2001zr500 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 4 02-05-2016 02:38 PM
2003 250 intermittent high idle?? custom1106 General ATV Discussion 4 01-28-2016 03:25 AM
idle issues koby36 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 6 01-17-2016 06:04 PM
96 zr580 efi idle problem Zr58044241 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 6 01-13-2016 09:38 AM

 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.