Reply
Old 01-02-2013, 01:54 AM   #1
Junior Member
 
Junior Member
Join Date: Jan 2013
Location: alberta ca
Thanks: 2
Thanked 1 Time in 1 Post
1994 wildcat 700 efi fuel pump problem

new to the forum. and looking forward to helping others in there dilemas but I'm stuck on this one. if I put ground to pink wire at at blue fuel pump relay relay clicks and fuel pump runs but this only tells me pump works and that relay works but not getting a ground signal from computer. oh yeh pink wire is about 10 inches long and goes straight to computer, question i have is this meaning computer is pouched or does it mean computer is not getting a signal telling it to send ground to pink wire. no codes at computer and sled starts up great if u wire pump to run constant but thats not gonna work i need help in trouble shotting this one. fuel pump wiring diagram would be awsome.
HappyG is offline   Reply With Quote
Remove Ads
Old 01-02-2013, 03:02 PM   #2
Senior Member
 
OldCat Rider's Avatar
 
Senior Member
Join Date: Feb 2006
Location: CNY
Thanks: 9
Thanked 275 Times in 270 Posts
Sled: '93 WildCat 700 EFI
ATV: 2002 Polaris Scrambler 500 4X4
There is also a fuse link wire that connects the ECU to the battery.
It has a green and brown wire in it. if the brown is blown, you will not get power to the relay for the pump.
OldCat Rider is offline   Reply With Quote
Old 01-02-2013, 09:30 PM   #3
Junior Member
 
Junior Member
Join Date: Jan 2013
Location: alberta ca
Thanks: 2
Thanked 1 Time in 1 Post
there is a inline fuse at the positive it is good and also red light comes on at dash and i can use kill switch to turn light off and on but fuel pump doesnt cycle unless i put ground to pink wire to cycle relay or by just putting power to purple wire that runs to pump i'll search forum for wire diagram. any help would be great and thanks OldCat for the help
HappyG is offline   Reply With Quote
Old 01-03-2013, 07:09 AM   #4
Member
 
Member
Join Date: Dec 2011
Location: saskatchewan canada
Thanks: 1
Thanked 10 Times in 10 Posts
Sled: 98 600efi Powder Spiecal / 97 EXT 580 EF
ATV: 04&06 Suzuki 400
I had the same problem on my 97 EXT EFI , found it was't grounding through the ECU . I wired in a toggle switch on dash to ground pump . just flip it on to go and works great , alsosaved buying a new ECU $$$$$ !
dickens is offline   Reply With Quote
Old 01-04-2013, 12:01 AM   #5
Junior Member
 
Junior Member
Join Date: Jan 2013
Location: alberta ca
Thanks: 2
Thanked 1 Time in 1 Post
so did your fuel pump run all the time ? and is your pump still working? I thought about doing this but wasnt sure if pump would last. and did your give any codes bud just asking cause mine just flashes once. is there a wiring diagram to what pin on computer does what? thanks for all the help forum is great help?
HappyG is offline   Reply With Quote
Old 01-04-2013, 07:29 AM   #6
Member
 
Member
Join Date: Dec 2011
Location: saskatchewan canada
Thanks: 1
Thanked 10 Times in 10 Posts
Sled: 98 600efi Powder Spiecal / 97 EXT 580 EF
ATV: 04&06 Suzuki 400
Pump does run all the time , but did before if engine was running !
Ask any auto mechanic , pump run all the time with your engine running. if there is a no start problem a timer in the ECU shuts the pump off after an allotted time . Your pump has to run all the time to keep your fuel rail pressured up , and the regulator dumps extra fuel not needed back to tank . No codes showed up just the single flash like yours . I just tapped into the black ground wire on the fuel pump and ran to ground from switch .

Last edited by dickens; 01-04-2013 at 07:31 AM.
dickens is offline   Reply With Quote
The Following User Says Thank You to dickens For This Useful Post:
HappyG (01-05-2013)
Old 01-04-2013, 07:41 AM   #7
Senior Member
 
OldCat Rider's Avatar
 
Senior Member
Join Date: Feb 2006
Location: CNY
Thanks: 9
Thanked 275 Times in 270 Posts
Sled: '93 WildCat 700 EFI
ATV: 2002 Polaris Scrambler 500 4X4
OldCat Rider is offline   Reply With Quote
The Following User Says Thank You to OldCat Rider For This Useful Post:
HappyG (01-05-2013)
Old 01-05-2013, 02:05 AM   #8
Junior Member
 
Junior Member
Join Date: Jan 2013
Location: alberta ca
Thanks: 2
Thanked 1 Time in 1 Post
with mine my ground is good at pump but ecu wont control relay to deliver power to it still I can do same as you by grounding at pink control wire at blue relay to control when pump gets power thanks alot guys like I said before forum is a great place for ideas.
HappyG is offline   Reply With Quote
Old 01-07-2013, 01:25 AM   #9
Junior Member
 
Junior Member
Join Date: Jan 2013
Location: alberta ca
Thanks: 2
Thanked 1 Time in 1 Post
installed a switch to control fuel pump and went for a drive today worked great but know a new problem lol my water pump gasket is leaking
HappyG is offline   Reply With Quote
Old 03-19-2013, 07:48 PM   #10
Junior Member
 
Junior Member
Join Date: Mar 2013
Location: waupaca, wi
Thanks: 0
Thanked 0 Times in 0 Posts
Pink Wire

I read above, are you saying you cut the pink wire and ground it? do you leave the relay in or all those other wires do nothing? I had no spark, screwed around for 2 days finally got spark if i took the fuel pump relay out, now after many times the fuel pump stopped working entirely but if i wire the fuel pump it runs, so what would happen if you just wired the fuel pump to the battery direct? just curious, not sure why if the fuel pump relay is in it has no spark, the comp blips the TSS code but i bypassed it. I called the dealer, they just said don't know, sleds to old.. mine is a 97 ext efi deluxe, if i dumped gas in cylinders it runs till out of fuel..
hammchuck is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar


Search tags for this page

1994 arctic cat wildcat 700 efi

,
94 wildcat 700 efi fuel pump wont turm on
,
94 wildcat 700 fuel pump issue
,
94 wildcat 700 fuel pump relay
,

arctic cat fuel pump

,

fuel pump for arctic cat wildcat 700 efi

,

fuel pump not turning on on a 94 wildcat 700

,
fusible link on a fuel pump on a 94 wildcat
,

how to test electric fuel pump on arctic cat snowmobile

,
where is the fuel pump relay on a 94 arctic cat efi
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 650 V2 fuel pump problem Mkenel Utility Performance / Technical info 7 09-27-2012 07:53 AM
wildcat fuel pump short alberta guy Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 3 02-18-2011 08:31 PM
Sticky oil pump arm trouble 1994 wildcat 700efi's sledhead1940 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 3 12-23-2010 07:32 AM
1994 zr 700 fuel pump setup???????? sledhead1940 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 0 11-09-2008 11:57 PM
03 F7 fuel pump problem mikethespyke XFR/Firecat/Sabercat 4 01-22-2007 11:05 AM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.