Fuel Pump - ArcticChat.com - Arctic Cat Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 01-22-2011, 04:20 PM Thread Starter
Senior Member
 
speedyspencer's Avatar
 
Senior Member
Join Date: Oct 2010
Location: Ontario
Posts: 229
Thanks: 10
Thanked 9 Times in 9 Posts
Sled: 99 ZL 500
ATV: None
Fuel Pump

So my fuel pump doesn't seem to be working on my 99 ZL500. It seems like i cant even get enough pressure to pull gas through the petcock valve let alone into the pump and through the carbs. I pulled the fuel pump apart and the diaphrams seem to be okay although i wouldn't know the difference but i didn't see anything unusual to make me think that that's the problem. I can blow through all the inlets and outlets off it also so it seems to me that it was okay. It looks like the pump creates pressure through a hose that looks like it connects under the mag side carb and works off of crankcase pressure? Can anyone let me know if that's the truth? Also if anyone has some tips on how to test a fuel pump or what i can do to make this work PLEASE let me know! I was also thinking about changing the fuel filter? Would a dirty one really cause enough resistance that the fuel pump wouldnt work? Thanks!
speedyspencer is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 01-22-2011, 06:51 PM Thread Starter
Senior Member
 
speedyspencer's Avatar
 
Senior Member
Join Date: Oct 2010
Location: Ontario
Posts: 229
Thanks: 10
Thanked 9 Times in 9 Posts
Sled: 99 ZL 500
ATV: None
speedyspencer is offline  
post #3 of 12 Old 01-23-2011, 11:08 AM Thread Starter
Senior Member
 
speedyspencer's Avatar
 
Senior Member
Join Date: Oct 2010
Location: Ontario
Posts: 229
Thanks: 10
Thanked 9 Times in 9 Posts
Sled: 99 ZL 500
ATV: None
Bump
speedyspencer is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 01-23-2011, 12:25 PM
Senior Member
 
extsp2's Avatar
 
Senior Member
Join Date: Dec 2005
Location: mass
Posts: 511
Thanks: 1
Thanked 34 Times in 34 Posts
Garage
Sled: 03 ZL600 ESR 136", 03 ZL 550 ESR
10-11 Mileage: 350
09-10 Mileage: 1000
08-09 Mileage: 850
07-08 Mileage: 1100
06-07 Mileage: 1200
ATV: 2000 Suzuki Quadrunner 500
you are correct, crankcase vacuum makes the fuel pump work. make sure that hose is connected and doesn't have any holes in it. a blocked fuel filter can definately cause no fuel to the carbs. make sure the filter is good. you probably need to rebuild/replace the pump. they are not much $$. good luck.

M.K.



2003 ZL600 ESR 136" 2002 ZL600 SS
2003 ZL550 ESR 2005 Sabercat 600
2001 ZR800 136" 2001 ZL 500 ESR
1998 ZR600 EFI LE 1998 ZR600 EFI
1992 EXT Special 1991 EXT Special
1985 Cougar 1981 El Tigre 6000
1980 Jag 3000 1972 Panther 292
extsp2 is offline  
post #5 of 12 Old 01-23-2011, 04:00 PM Thread Starter
Senior Member
 
speedyspencer's Avatar
 
Senior Member
Join Date: Oct 2010
Location: Ontario
Posts: 229
Thanks: 10
Thanked 9 Times in 9 Posts
Sled: 99 ZL 500
ATV: None
well i can get one from royal distributing for 31 dollars as compared to 80 from dealer but i took it apart and it seems ok? but im not too sure what to look for....have you ever rebuilt a pump? is it ust a matter of replacing the black diaphrams in it?
speedyspencer is offline  
post #6 of 12 Old 01-23-2011, 04:40 PM
Member
 
Member
Join Date: Nov 2010
Location: MN.
Posts: 99
Thanks: 0
Thanked 3 Times in 3 Posts
Sled: 02 550zl (2) 97 puma 94 indy lite
10-11 Mileage:
09-10 Mileage: 1200
08-09 Mileage: 800
A good test for a fuel pump is pull the fuel line and give it a pull. The fuel should shoot out of the fuel line like a foot or two if not somthing is up. Fuel pumps last a long time check the vacumm line. If it's your pump you just need a rebiuld kit.

Dan
fishing star is offline  
post #7 of 12 Old 01-23-2011, 05:09 PM
Member
 
timmmurphy1995's Avatar
 
Member
Join Date: Jan 2011
Location: Goshen, New Hampshire
Posts: 60
Thanks: 1
Thanked 1 Time in 1 Post
Garage
Sled: 1999 Arctic Cat Z.R. 500+
Run new fuel, oil, anti-freeze coolant, and clean your carbs.


1999
Arctic Cat Z.R. 500+
(80 c.c. Bore-Over w/ Wilwood Hydraulic Clutch & Braking System & F.M.F. Rumble Pack Exhaust System)

timmmurphy1995 is offline  
post #8 of 12 Old 01-23-2011, 08:07 PM Thread Starter
Senior Member
 
speedyspencer's Avatar
 
Senior Member
Join Date: Oct 2010
Location: Ontario
Posts: 229
Thanks: 10
Thanked 9 Times in 9 Posts
Sled: 99 ZL 500
ATV: None
It has a whole tank of new fuel and i can't see how new oil and coolant would help with this issue and even so thats all also new. The carbs have been cleaned this year also very well with new gaskets and i know the gas wasn't in there long enough to varnish up to the point that it would cause a block. The pump doesn't shoot fuel from it so that's why im suspecting it to be the pump or something wrong with the vacuum line but I just can't figure out why the vacuum line would all of a sudden not have vacuum. I did have a wee problem getting them primed before but the pump still shot fuel out. Im going to order a new pum for 30 bucks of Royal Distributing and let you guys know just for reference. Thanks all!
speedyspencer is offline  
post #9 of 12 Old 01-24-2011, 05:42 AM
Senior Member
 
extsp2's Avatar
 
Senior Member
Join Date: Dec 2005
Location: mass
Posts: 511
Thanks: 1
Thanked 34 Times in 34 Posts
Garage
Sled: 03 ZL600 ESR 136", 03 ZL 550 ESR
10-11 Mileage: 350
09-10 Mileage: 1000
08-09 Mileage: 850
07-08 Mileage: 1100
06-07 Mileage: 1200
ATV: 2000 Suzuki Quadrunner 500
so the vacuum line is in good shape? is the fuel filter not clogged? i've never rebuilt the pumps, just replaced them.

M.K.



2003 ZL600 ESR 136" 2002 ZL600 SS
2003 ZL550 ESR 2005 Sabercat 600
2001 ZR800 136" 2001 ZL 500 ESR
1998 ZR600 EFI LE 1998 ZR600 EFI
1992 EXT Special 1991 EXT Special
1985 Cougar 1981 El Tigre 6000
1980 Jag 3000 1972 Panther 292
extsp2 is offline  
post #10 of 12 Old 01-25-2011, 11:26 AM Thread Starter
Senior Member
 
speedyspencer's Avatar
 
Senior Member
Join Date: Oct 2010
Location: Ontario
Posts: 229
Thanks: 10
Thanked 9 Times in 9 Posts
Sled: 99 ZL 500
ATV: None
Im not too sure if the filter is clogged, there is gas on the side that leaves the filter but im going to replace it nayways cause it probably hasnt been replaced since 99 lol
speedyspencer is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone have Fuel pressure regulator/ fuel pump issues on a firecat firecatF?? XFR/Firecat/Sabercat 4 11-15-2011 09:19 PM
No Fuel. Unless I jump the Fuel Pump sbfisher Touring, Pather/pantera...ect 1 01-18-2010 07:46 PM
Any suggestions for fuel pump setups for 2001 sno pro 440 to 700 fuel inj. conversion? stuntmandave Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 6 11-05-2007 09:35 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome