Reply
Old 12-19-2010, 06:28 PM   #11
Senior Member
 
catspaz8's Avatar
 
Senior Member
Join Date: Jul 2004
Location: South Elgin, IL.
Thanks: 1
Thanked 30 Times in 30 Posts
Sled: 07' Doo 1000X Gade , 01' ZR800/900
10-11 Mileage:
09-10 Mileage: 1500
08-09 Mileage: 2500
07-08 Mileage: 2700
06-07 Mileage: 2000
check your clutches over as well, make sure there are no broken springs in either clutch, as well any flat spots in the rolling surfaces of the weights or rollers.Check the weights bushing as well to make sure they aren't worn and hanging up on the towers.
catspaz8 is offline   Reply With Quote
Remove Ads
Old 12-19-2010, 07:54 PM   #12
Senior Member
 
Senior Member
Join Date: Apr 2009
Location: Canada
Thanks: 6
Thanked 2 Times in 2 Posts
Sled: 2005 f7 efi black widow
10-11 Mileage: 1500
09-10 Mileage: 2500
08-09 Mileage: 700
how do you check the weights for hang up?? Also how do i check the stator to see if it is causing this??
taillon is offline   Reply With Quote
Old 01-26-2011, 07:56 PM   #13
Junior Member
 
Junior Member
Join Date: Dec 2010
Thanks: 0
Thanked 0 Times in 0 Posts
same thing 7000 limit

I have a 98 zrt 600 it is doing the same thing. WILL not go over 7 - 7200 rpms. Starts missing and sounding boggey. Have tried everything different clutches currently clean as hell and both stock with new belt and shafts aligned. Carbs all back to stock except needle valve. current is a p 480 stock calls for a p2 480 on the way though. Need to find a rebuild kit for fuel pump. what pump is in these. Replacing resister caps also will know more tomorrow afternoon any more info would be good. thanks.
jburns is offline   Reply With Quote
Old 01-26-2011, 08:24 PM   #14
Junior Member
 
Junior Member
Join Date: Jan 2011
Location: North Dakota
Thanks: 0
Thanked 0 Times in 0 Posts
I had a 98 powder extreme that would do the same thing I repaired the clutches and cleaned carbs and checked everything electrical and it still wasn't fixed. I finally took the air box out and the inlets have a really fine screen over them and the screens had an oily film on them. I cleaned the screens put it back together and was turning 8500 rpms again.
Vernb55 is offline   Reply With Quote
Old 01-26-2011, 08:53 PM   #15
Junior Member
 
Junior Member
Join Date: Dec 2010
Thanks: 0
Thanked 0 Times in 0 Posts
I bad a prob like that it was the stator. I used blaines you tube post to check it. it takes 5 min . i went from goin 45and 50 to over 100mph
gota have green is offline   Reply With Quote
Old 01-26-2011, 09:13 PM   #16
Member
 
Member
Join Date: Sep 2008
Location: onatrio
Thanks: 2
Thanked 4 Times in 4 Posts
Sled: ZRT 800
07-08 Mileage: don't know
06-07 Mileage: don't know
same thing happend to my sled would only rev to 7400 rpm , nothing i would do fixed it the tried another startor that was good and it was fixed
ZRT800kid is offline   Reply With Quote
Old 01-29-2011, 09:52 AM   #17
Junior Member
 
Junior Member
Join Date: Dec 2010
Thanks: 0
Thanked 0 Times in 0 Posts
I tested stator got 448 and 20.6 but didnt get the sum of both on other test whats that mean? Thanks
jburns is offline   Reply With Quote
Old 01-29-2011, 09:59 AM   #18
Senior Member
 
arcticcatzrt600's Avatar
 
Senior Member
Join Date: Jan 2011
Location: huron
Thanks: 2
Thanked 5 Times in 5 Posts
 Quote: Originally Posted by taillon View Post
i have an egt gauge and all three cylinders are firing and at the same temp! I have the tss jumped already... the "rev limiter feeling" is all over the place 5-6-7000 rpm but will not go over 7000...it also seems to get worse when it is warmer!! I also noticed that the buttons on the secondary clutch are only going halfway up the helix, are they supost to go all the way to the bottom of it??

Would it be a good idea to start and run the sled without the belt to see if it will go past 7000 without the belt..could this determine if its on the clutch or the engine??
i have this issue mine was because mine was jetted to big
arcticcatzrt600 is offline   Reply With Quote
Old 01-29-2011, 06:37 PM   #19
Sponsors
 
kev's Avatar
 
Sponsors
Join Date: Aug 2005
Location: Georgetown, ON Canada
Thanks: 95
Thanked 189 Times in 188 Posts
Sled: 95 ZRT 800 AGLT, 92 Jag 440
10-11 Mileage: 800
09-10 Mileage: 679
08-09 Mileage: 1000
07-08 Mileage: 1600
06-07 Mileage: 728
ATV: 50cc
 Quote: Originally Posted by jburns View Post
I tested stator got 448 and 20.6 but didnt get the sum of both on other test whats that mean? Thanks
Probably didn't get the meter lead in all the way, on didn't get the right pin. Those readings are almost perfect for your sled. That isn't a guarantee it's not the cause of your symptom though.
__________________
Stator rewinds, 2 year warranty.
www.StatorKev.com
kev is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar


Search tags for this page
2001 zl 600 wont rev past 7000 no power
,

440 skidoo wont rev past 7000 rpm when warm

,
98 zrt 800 rev limiter?
,

my 2002 arctic cat zr 600 will not rev over 7000 rpm

,

ski doo snowmobile cuts out and misses at 7000 rpm

,
ski doo wont rev pass 6 thousand rpm
,

sled only runs 7000 rpms an will go 50

,
snowmobile not getting past 6000 rpm
,

wiring harness for a 1998 grand touring 7000

,

zrt 800 wont rev past

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
04 fircat wont go over 7000 rpms sirinek14 XFR/Firecat/Sabercat 2 02-09-2010 10:28 AM
2002 ZR600 EFI CC Can not build rpms past 6500 to 7000 geeman Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 17 01-31-2010 08:38 AM
wont rev over 7000 ZR580SRX Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 4 01-11-2010 08:20 AM
wont go past 7000 rpms? austinruler Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 3 01-03-2010 01:45 PM
M7 sputter past 7000 sled basher M7 M Series/Mtn. 3 01-18-2007 10:18 PM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.