XFR/Firecat/Sabercat Regular 128" XF / Firecat/Sabercat chassis

Reply
Old 03-09-2013, 12:06 AM   #1
Junior Member
 
Junior Member
Join Date: Mar 2013
Location: pine bush ny
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 05 firecat f7 efi
05 f7 efi

hi new here to the site so ill say a little about my sled....

05 f7 efi diamond drive
v-force 3 reeds
air box upgrade
shaved heads
d&d y pipe and can
06 secondary clutch
green spring in primary runs on 044 belt
adjustable fuel pressure regulator set at 44 psi
141 studs 1.325
six inch bar riser


these things all done when i bought the sled i hanvt done any of it myself sled runs like a beast .... set up 660 on ice and whooped up on ski-doo 1000 machz f8 f1000 zrt800 and zr800 and yamaha rx1 very happy with that ....

now issues and problems i am having

so i was away this past week and did 350 miles of trail rideing upstate ny and on out last day i ran into a problem.... my pull start/recoil exploded and broke.... anyone ever have this problem?
and it seems that the sled is pulling nice and hard off the start but gets to 7000 rpm and comes down to 6000 for a sec then reves up to 7800-8000 what could be the issue here? like a mid range dead spot....then pulls hard up top never had this problem till like 2 weeks ago.
thanks for the help
dan
buddha823 is offline   Reply With Quote
Remove Ads
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » XFR/Firecat/Sabercat


Search tags for this page
05 f7 efi
,
05 f7 efi hard pull start
,
05artic cat efi f7
,

arctic cat f7 efi 05

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



Garage Plus vBulletin Plugins by Drive Thru Online, Inc.