04 Electronic Fuel Gauge - ArcticChat.com - Arctic Cat Forum

XFR/Firecat/Sabercat Regular 128" XF / Firecat/Sabercat chassis

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 Old 02-20-2010, 11:24 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Jan 2010
Location: Mid-Michigan
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2004 Sabercat 700LX EFI
I have a 2004 Sabercat 700 LX EFI with the Premium Speedometer. I know the "bars" for the fuel level are suppose to show up, but mine seems to not be working correctly and are not displaying on the screen.

This is what it is supposed to look like -



Any suggestions?

GreenF570 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 Old 02-21-2010, 07:52 AM
Senior Member
 
Senior Member
Join Date: Nov 2009
Location: Concord NH
Posts: 148
Thanks: 0
Thanked 3 Times in 3 Posts
Sled: 2002 zl 550, 2004 sabercat 700
10-11 Mileage: 4000
09-10 Mileage: 2000
08-09 Mileage: 1600
Mine does the same thing. Worked last year, worked at the beginning of this year, then after the first fill and ride it just says full all the time. Might be a stuck float, but I have not had a chance or a low enough tank to stuff my hand in there and check it.
catridingogre is offline  
post #3 of 17 Old 02-21-2010, 08:23 AM
Senior Member
 
acfirecat600's Avatar
 
Senior Member
Join Date: Apr 2009
Location: Hartford County, Connecticut
Posts: 399
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2005 F6 EFI
10-11 Mileage: 300-400?
09-10 Mileage: 1533 and done
on firecats they dont do anything.. im pretty sure only on the T660 they work as an electronic gas gauge



Only a Ford pulls my cat down the road
acfirecat600 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 Old 02-21-2010, 09:45 AM
Member
 
Dustin0285's Avatar
 
Member
Join Date: Dec 2007
Location: Saskatchewan, Canada
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2012 XF1100 SnoPro Ltd.
07-08 Mileage: 3100
acfirecat600 is right. No firecats/sabercats came with an electronc fuel guage. The bars are there for other models that use the same guage cluster and have an electronic level sender.
Dustin0285 is offline  
post #5 of 17 Old 02-21-2010, 10:59 AM
Senior Member
 
Senior Member
Join Date: Oct 2009
Location: On
Posts: 204
Thanks: 0
Thanked 3 Times in 3 Posts
Sled: 06 AC 600 Factory Mod
08-09 Mileage: 400
07-08 Mileage: 1100
ATV: 09 grizzly 700 fi
2010 Mileage: 350
2009 Mileage: 350
that is not a fuel gauge. look down at your gas tank and you will see the proper one.
ski-doo600mod is offline  
post #6 of 17 Old 02-21-2010, 02:45 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Jan 2010
Location: Mid-Michigan
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2004 Sabercat 700LX EFI
Then why in this picture i have posted is a 2004 Sabercat IDENTICAL to mine (minus the color) and the fuel gauge on the speedo works?
GreenF570 is offline  
post #7 of 17 Old 02-21-2010, 03:16 PM
Senior Member
 
acfirecat600's Avatar
 
Senior Member
Join Date: Apr 2009
Location: Hartford County, Connecticut
Posts: 399
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2005 F6 EFI
10-11 Mileage: 300-400?
09-10 Mileage: 1533 and done
<div class='quotetop'>QUOTE (GreenF570 @ Feb 21 2010, 03:45 PM) <{POST_SNAPBACK}></div>
Quote:
Then why in this picture i have posted is a 2004 Sabercat IDENTICAL to mine (minus the color) and the fuel gauge on the speedo works?[/b]
some type of mod?? guy figured out how to make it work? no clue, just know it wasnt set up to work on the fcats/sabercats



Only a Ford pulls my cat down the road
acfirecat600 is offline  
post #8 of 17 Old 02-21-2010, 05:05 PM
Senior Member
 
Senior Member
Join Date: Oct 2009
Location: On
Posts: 204
Thanks: 0
Thanked 3 Times in 3 Posts
Sled: 06 AC 600 Factory Mod
08-09 Mileage: 400
07-08 Mileage: 1100
ATV: 09 grizzly 700 fi
2010 Mileage: 350
2009 Mileage: 350
those bars light up like that on everyones sabercats and firecats. mine has the little bars on the side as well. if yours is not showing them then your speedo must not be working.
ski-doo600mod is offline  
post #9 of 17 Old 02-21-2010, 05:58 PM
Senior Member
 
acfirecat600's Avatar
 
Senior Member
Join Date: Apr 2009
Location: Hartford County, Connecticut
Posts: 399
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2005 F6 EFI
10-11 Mileage: 300-400?
09-10 Mileage: 1533 and done
<div class='quotetop'>QUOTE (ski-doo600mod @ Feb 21 2010, 06:05 PM) <{POST_SNAPBACK}></div>
Quote:
those bars light up like that on everyones sabercats and firecats. mine has the little bars on the side as well. if yours is not showing them then your speedo must not be working.[/b]
X2, yeah they should always be there but not functional



Only a Ford pulls my cat down the road
acfirecat600 is offline  
post #10 of 17 Old 02-22-2010, 10:17 AM
Senior Member
 
Senior Member
Join Date: Sep 2009
Location: ny
Posts: 126
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 04 f6
is there a way to make them work on the firecats it would be more accurate that way
greencatf6 is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > XFR/Firecat/Sabercat

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome