87 Pantera 440 l/c occasional low idle and bogs - ArcticChat.com - Arctic Cat Forum
NavbitArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » Vintage 1992 older » 87 Pantera 440 l/c occasional low idle and bogs

Reply
Old 12-28-2016, 12:22 PM   #1
Junior Member
 
Junior Member
Join Date: Dec 2016
Location: Maine
Thanks: 0
Thanked 0 Times in 0 Posts
87 Pantera 440 l/c occasional low idle and bogs

When you start the sled and let it idle it's absolutely fine, once you start moving again all is well but it's not long before it starts feeling like it needs more gas to get moving or stay moving and eventually starts bogging around 4000-5000 rpms and doesn't want to move. When I stop it idles real low and rough but if I leave it alone a second it will slowly idle back up and run right all on its own and it's back down the trail a few feet until it happens again. I've cleaned carbs, done a fuel pump rebuild, plugs aren't running lean... I'm absolutely stumped, supposed to get snow tomorrow and really want to ride! Thanks for the help!
Arctakitty1987 is offline   Reply With Quote
Remove Ads
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » Vintage 1992 older

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eltigre bogs bad, please HELP!! Mattperk Vintage 1992 older 8 12-21-2016 05:45 PM

 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.