04 650 V2 Belt Light Constant on - ArcticChat.com - Arctic Cat Forum

Utility Performance / Technical info Utility ATV Performance and Technical Discussions about specific mods, engine upgrades!

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 02-24-2009, 09:58 AM Thread Starter
Junior Member
 
Junior Member
Join Date: Feb 2009
Location: Michigan
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: N/A
ATV: 2004 650 V2
2008 Mileage: 200
2007 Mileage: 150
Anyone know how to solve this? Problem is belt light is on and can't get it to reset using jumper plug and procedure. Belt looks good and machine is not in limp mode. Cause unknown but was riding on lake with 1.5 inches of water on the ice when light appeared.
04' 650 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-24-2009, 11:29 AM
Senior Member
 
Timberwolf's Avatar
 
Senior Member
Join Date: Jan 2009
Location: Indiana
Posts: 451
Thanks: 0
Thanked 0 Times in 0 Posts
ATV: 05 650 V2
it is just telling you to take it in for service...something AC did to get you to take it back to the dealer. someone will chime in on how to get it to go off...
Timberwolf is offline  
post #3 of 5 Old 02-24-2009, 11:42 AM
Team ArcticChat
 
CrazyYooper's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Jun 2005
Location: North Dakota
Posts: 3,539
Thanks: 1
Thanked 8 Times in 8 Posts
ATV: 2004 Arctic Cat 800 LE
2007 Mileage: 650
2006 Mileage: 300
Mine did that and I could not get it to go out, the dealer looked at it and he couldn't get it to go out either so I went and got a Dynatek cdi and now I don't have any belt light problems

04 650 LE
EPI maroon primary
Brute Force 750 secondary
EPI wieghts
FST cams and valve springs
dynatek CDI module
28" Mudlites
26" outlaws
Hosstoppers
V-Force crank and rods
FST 765 Big Bore Kit
200 front jet 195 rear jet
Speedwerx exhaust
open air box
Ram GPS mount
BF 750 Belt
carb slide mod
ported heads
K&N air filter
YZF oil catch can
HighLifter Oil Coooler
Arctic Cat Plow
Temp Gauge
AC brush guard
AC rear bumper
Shane Mod
vision 161 brusier wheels
1" handlebar riser
front and rear brake levers
inner fender wells
Arctic FX custom decals
CrazyYooper is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 02-24-2009, 03:28 PM
Team ArcticChat
 
Sanny651's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Sep 2005
Location: MN
Posts: 19,623
Thanks: 31
Thanked 228 Times in 170 Posts
ATV: 2013 550 XT
I'm on my work laptop now so I don't have the link, but when I get on my home PC I'll give you the directions on how to reset it. Gravy. 1 minute tops.
Sanny651 is offline  
post #5 of 5 Old 02-24-2009, 03:34 PM
Team ArcticChat
 
Sanny651's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Sep 2005
Location: MN
Posts: 19,623
Thanks: 31
Thanked 228 Times in 170 Posts
ATV: 2013 550 XT
Sanny651 is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > Utility ATV repair and maintenance & Troubleshooting > Utility Performance / Technical info

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome