Speedo Display flashes "Volt" - ArcticChat.com - Arctic Cat Forum

Utility Performance / Technical info Utility ATV Performance and Technical Discussions about specific mods, engine upgrades!

 
LinkBack Thread Tools Display Modes
post #1 of 9 Old 12-02-2007, 01:14 PM Thread Starter
Senior Member
 
Senior Member
Join Date: Jan 2006
Location: St. Cloud, MN
Posts: 103
Thanks: 0
Thanked 4 Times in 4 Posts
Sled: '14 XF 8000 CC Sno Pro
ATV: '07 650 H1
Was plowing today for the 2nd time with my '07 650 H1, and looked down and the speedo display was flashing "volt". I was thinking that since i have the OEM battery that it maybe wasn't large enough (as i've read in many posts).

Is this the case? Is that why i'm seeing this on the display? I didn't lose power, but was just about done with the plowing, so wanted to make sure before i went out and bought a new battery.

Thanks much!

BTW ---- plowing was a blast!!!!


summett is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-02-2007, 01:26 PM
Senior Member
 
RiverCat 650's Avatar
 
Senior Member
Join Date: Jun 2004
Location: Riding
Posts: 1,559
Thanks: 0
Thanked 1 Time in 1 Post
Sled: Radio Flyer 1000cc
ATV: 2007 700 efi
2007 Mileage: 34
mines done that twice . its sayn your voltage is droping and its a preset default in your system to montor . i have a power angler and winch kift and extra lites . i have to trickle charge my battery when im done . been thinkn aboput a bigger batt. or even a sencond batt,.

2007 700 EFI
rivercat 650 stick stoppers
backup lites .
under fender lites for rock crawling @ night
snorkels.
2in rivercat lift.
26 itp terra cross on 112 itps
frt&rear 2500# warns
cut fender mod.
cat hand gaurds.
bobed rear bumper..
ITS A CAT THING
RiverCat 650 is offline  
post #3 of 9 Old 12-02-2007, 03:22 PM
Team ArcticChat
Team ArcticChat
 
Team ArcticChat
Join Date: Aug 2006
Location: Billerica ma.
Posts: 2,508
Thanks: 0
Thanked 3 Times in 2 Posts
ATV: 2006 arctic cat 400 4x4 auto fis
2008 Mileage: 410
2007 Mileage: 500
2006 Mileage: 900
its low power on your battery its montiored by your bike and when to low it warnes you try plowing without your headlights on if you dont already it helps a bigger battery will also help. the winch is a big draw on the battery and the stock isnt really all that well at handling the extra load. if you dont want to buy a bigger battery try not using your headlites if you have handwarmers or any extra load dont use them but ultimately a bigger battery will do the trick

27-9-14 swamplites
27-11-14 swamplites
14" itp ss 108 black
2" snorkels
speedwerx clutch kit
carbslide mod
front brush bar
kimpex atv lounger
chopped front bumper
gorilla 3000# winch

join the team-------click here--------->
www.myspace.com/rango726
rango726 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 12-02-2007, 05:06 PM
Team ArcticChat
 
Rugby3's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Dec 2005
Location: Duplin County NC
Posts: 1,097
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2001 F-250 V10 Crew Cab
ATV: 2006 650V2
Other have hit it on the head, normal if your using extra lights in addition to your lights and any kind of extended winch use will definitely give ya the "volt" warning. I have had that happen several times when making some heavy and longer winch pulls.

<span style="font-family:Century Gothic">06 650V2
28" Swamp Fox +&#39;s
Fully Snorked, Chipped, Sprung
Rad Relocated
AC Swaybar
Bill the Cat riding Lead

07 Lime Green 500
27" Swamp Fox+&#39;s
Fully Snorked
AC Swaybar

07 Red 400
26" Swamp Fox+&#39;s
Fully Snorked
AC Swaybar</span>
Rugby3 is offline  
post #5 of 9 Old 12-02-2007, 08:33 PM Thread Starter
Senior Member
 
Senior Member
Join Date: Jan 2006
Location: St. Cloud, MN
Posts: 103
Thanks: 0
Thanked 4 Times in 4 Posts
Sled: '14 XF 8000 CC Sno Pro
ATV: '07 650 H1
Great...thanks for the info! I am looking into a little stronger battery i think, but appreciate the input!



summett is offline  
post #6 of 9 Old 12-02-2007, 09:11 PM
Junior Member
 
Junior Member
Join Date: Dec 2007
Location: swan river manitoba
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: firecat 700 sno pro
07-08 Mileage: 140
06-07 Mileage: 300
ATV: arctic cat 400
2007 Mileage: 100
2006 Mileage: 120
i don't know if that will really make a diff casue it does that to my neighbore lots and all he does is disconnect the battery and reconeccs it and it works good
ccm89 is offline  
post #7 of 9 Old 12-03-2007, 08:33 AM
Senior Member
 
mudlover's Avatar
 
Senior Member
Join Date: Oct 2007
Location: Grandbay, NB, Canada
Posts: 141
Thanks: 0
Thanked 0 Times in 0 Posts
ATV: Arctic cat TRV 650H1 LE
2007 Mileage: 000+
I have had this come up a couple of times, like previously noted both times involved extended winching, both times all I did was let the bike run for a while to build the charge back up and then shut the bike off and the volt error automatically reset. Also noticed that when the low "volt" reading appeared I would also lose my 4x4 unless I was in locked position(I would still have the left front side). Has anyone else experianced this happening.
FYI I get full posi back after the error is cleared.
mudlover is offline  
post #8 of 9 Old 12-03-2007, 10:51 AM
Senior Member
 
tnewguy's Avatar
 
Senior Member
Join Date: Dec 2005
Location: Manitoba, Canada
Posts: 140
Thanks: 0
Thanked 0 Times in 0 Posts
ATV: 2006 500 auto
happened a few times to me too. i just shut it off, then restart it works fine, lol

06 500 auto
27-12-12 mudlites rear
27-10-12 mudlites front
2500 warn winch
kimpex rear seat

It is impossible to lick your elbow
tnewguy is offline  
post #9 of 9 Old 12-23-2007, 12:01 PM
Member
 
Member
Join Date: Jul 2007
Location: prince george
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
06-07 Mileage: 1000
ATV: cat v650
2007 Mileage: 1300
mine did the same thing. it mostly comes from stalling out the winch. it takes so much amperage out of the battery that the stater cant keep up thus sending u a message. mine took so much out of the battery that it killed the engine!!! soooo on goes a small car battery up frnt and moved the cables to that battery. can get about 4hr of plowing before it needs to be charged up, dont matter any way just throw the battery chager on trickle and leave it for next time. for me its been the next day lol...
stujoe is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > Utility ATV repair and maintenance & Troubleshooting > Utility Performance / Technical info

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome