Arctic Cat 650 V2 not running well - ArcticChat.com - Arctic Cat Forum

Utility ATV repair and maintenance & Troubleshooting Place your Utility ATV Repair and Maintenance questions/thoughts here... *not performance*

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-15-2012, 02:48 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Dec 2011
Location: Oakdale, MN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
ATV: 2006 Arctic Cat 650 V2
Arctic Cat 650 V2 not running well

My buddy has a 2005 Arctic Cat 650 V2. it's not running well. It starts and idles fine. when you drive it and give it gas, it doesn't go very fast at all. It feels like it's not getting gas. We have tore the carbs apart more times than I want to. We checked fuel pressure and it's good. It has commpression. Any suggestions??
Wawina is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-15-2012, 03:06 PM
FCC
Senior Member
 
FCC's Avatar
 
Senior Member
Join Date: Jul 2011
Location: Mx
Posts: 433
Thanks: 77
Thanked 16 Times in 16 Posts
Garage
Sled: 48 qt coleman cooler
ATV: 2005 650 V2
need more details.

is smoke coming from the tail pipe?
have you checked the plugs?
when you had your carbs out, did you disassembled them ALL the way? like, take out the decel diapraghm and the pms screws with their o-rings?
have you checked if your slides are moving when you apply throttle?

2005 650 V2
K&N AIR FILTER
HMF EXHAUST
DYNOJET KIT
SLIDE MOD
SNORKELED
BIG HORNS 2.0s ON 2012 LTD RIMS
NGK DOUBLE ELECTRODE PLUGS
DRILLED SS BRAKE ROTORS
REAR TRUNK WITH SEAT & COOLER!
FCC is offline  
post #3 of 4 Old 10-15-2012, 04:58 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Dec 2011
Location: Oakdale, MN
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
ATV: 2006 Arctic Cat 650 V2
It's not smoking out of the tail pipe any more than it used to (running rich), which is a HMF aftermarket pipe.
plugs are good.
I'll have to ask him about the carbs...
Wawina is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 10-15-2012, 05:28 PM
FCC
Senior Member
 
FCC's Avatar
 
Senior Member
Join Date: Jul 2011
Location: Mx
Posts: 433
Thanks: 77
Thanked 16 Times in 16 Posts
Garage
Sled: 48 qt coleman cooler
ATV: 2005 650 V2
Quote:
Originally Posted by Wawina View Post
It's not smoking out of the tail pipe any more than it used to (running rich), which is a HMF aftermarket pipe.
plugs are good....
if it is smoking, even a little, yes, you're running rich. Check the choke cables, is a known flaw in these atv's they tend to stick open, resulting in an overall rich condition.

2005 650 V2
K&N AIR FILTER
HMF EXHAUST
DYNOJET KIT
SLIDE MOD
SNORKELED
BIG HORNS 2.0s ON 2012 LTD RIMS
NGK DOUBLE ELECTRODE PLUGS
DRILLED SS BRAKE ROTORS
REAR TRUNK WITH SEAT & COOLER!
FCC is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > Utility ATV repair and maintenance & Troubleshooting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 Arctic Cat 650 H1 running issue CAT COUNTRY Utility ATV repair and maintenance & Troubleshooting 5 03-30-2012 03:55 PM
2002 Arctic Cat 300 ATV won't keep running. PSAMM Utility ATV repair and maintenance & Troubleshooting 3 03-05-2012 01:06 PM
Arctic Cat 400 4x4 not running dbrewer12345 Utility ATV repair and maintenance & Troubleshooting 3 10-05-2011 05:30 PM
2003 arctic cat 90 running problems donald1975 Utility ATV repair and maintenance & Troubleshooting 0 06-18-2011 01:22 PM
1994 Arctic Cat Jag that won't keep running kipper1080 Touring, Pather/pantera...ect 3 01-26-2011 05:03 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome