05 arctic cat 500 hard start when cold - Page 2 - ArcticChat.com - Arctic Cat Forum

Utility ATV repair and maintenance & Troubleshooting Place your Utility ATV Repair and Maintenance questions/thoughts here... *not performance*

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 11 Old 09-29-2012, 04:01 PM Thread Starter
Member
 
Member
Join Date: Sep 2011
Location: mass
Posts: 42
Thanks: 0
Thanked 1 Time in 1 Post
Thank you so much for all the advice! Works great now. Plugs are new.. 1300miles in it.. I've went thru everything on it.. But this cold start thing was bugging me!

When I ride in the winter in New Hampshire or Maine I'm always afraid of killing the battery first ride of the day.. 5 below zero!
solerunner is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > Utility ATV repair and maintenance & Troubleshooting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
04 zr 900 EFI, hard to start cold. jasenb Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 2 12-22-2011 07:53 PM
hard to start when cold mustangfever Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 15 11-16-2010 07:43 AM
650 mud pro hard to start when cold robdina Utility Performance / Technical info 5 10-02-2010 05:41 PM
Hard to start when cold rmoody04 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 6 01-21-2008 08:39 AM
Hard to start when cold?? cbftbl87 XFR/Firecat/Sabercat 1 11-26-2007 07:49 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome