Help battery wont keep a charge - ArcticChat.com - Arctic Cat Forum

Utility ATV repair and maintenance & Troubleshooting Place your Utility ATV Repair and Maintenance questions/thoughts here... *not performance*

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-18-2012, 02:56 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Jun 2012
Location: Pennsylvania
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Question Help battery wont keep a charge

Hi my 2009 550 trv le h1 will not charge the battery is it the sonenoid or voltage regulator or it it a bad magneto
chaz5920 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 06-18-2012, 03:24 PM
Senior Member
 
catwalkin's Avatar
 
Senior Member
Join Date: Apr 2009
Location: maine
Posts: 1,337
Thanks: 1
Thanked 44 Times in 41 Posts
Garage
Sled: sold
ATV: 09 700mp
2009 Mileage: so far 4900
what your going to have to do to find the issue is
find a flow chart for a no charging condition for your machine.
have a multi meter step by step the flow chart will list component tests along with wiring output tests..key on and off..

OUTLAWS 29,5S x12,S x 4
BIGHORN 29X11X14 X4
14IN STI BEADLOCKS
4WHL DISC BRAKES
ELKA STG 4 REAR SHOCKS
ELKA STG 4 FRONT SHOCKS
PRECISION STEERING DAMPER
KC DAYLIGHTERS
FIXED PLATE MOD
700H1 SLEEVE
4 19G ROLLERS(RED)
GOIN CRAWLIN
NUFF SAID
OFTEN IMITATED BUT NEVER DUPLICATED
catwalkin is offline  
post #3 of 5 Old 06-18-2012, 04:01 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Jun 2012
Location: Pennsylvania
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Humm where do i find a flow chart
chaz5920 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 06-18-2012, 05:40 PM
Banned
 
Banned
Join Date: Jul 2005
Location: Colorado 4,500-10,500 ft.
Posts: 597
Thanks: 1
Thanked 42 Times in 41 Posts
Sled: 2011 M8, 2006 M7
10-11 Mileage: 1799
09-10 Mileage: 1500
08-09 Mileage: 1500
07-08 Mileage: 1200
06-07 Mileage: 200
ATV: 2009,2010 Mud Pro 700's, 2006 500 manual
2010 Mileage: 1246
2009 Mileage: 1568
2008 Mileage: 1187
2007 Mileage: 600
2006 Mileage: 1000
Quote:
Originally Posted by chaz5920 View Post
Hi my 2009 550 trv le h1 will not charge the battery is it the sonenoid or voltage regulator or it it a bad magneto
So when you have your multimeter hooked to the battery when it's off what does it read?
So when you have your multimeter hooked to the battery when it's running what does it read?
Winch_Warrior is offline  
post #5 of 5 Old 06-19-2012, 11:51 AM
Senior Member
 
fijjity's Avatar
 
Senior Member
Join Date: Feb 2005
Location: Oscoda, MI
Posts: 2,564
Thanks: 17
Thanked 131 Times in 123 Posts
Sled: 2001 Mountain Cat 1000
charge the battery on a trickle charger 2 amp setting for 24 hrs. load test battery. If it tests good, then install it and start the atv. put a multi meter set to VDC and make sure it is charging more than 12VDC or battery voltage. If the system isn't putting out the correct VDC, then it could be the regulator or the stator not putting out. At that point, take it to a shop cause it is a little more to test the other things and if you are not sure what it is now, the rest of it may be over your head.

2001 Mountain Cat 600 EFI LE
fijjity is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > Utility ATV repair and maintenance & Troubleshooting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZR 580 Wont charge battery ak49john Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 11 02-17-2012 03:55 PM
96 zr 580 efi battery wont charge markanddiane09 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 3 12-13-2011 10:21 AM
Battery Won't Charge jdrost General Snowmobile Discussion 8 02-14-2011 03:43 PM
650 H1 LE Battery Wont Charge pondtunes General ATV Discussion 0 10-25-2010 03:01 PM
1995 zr 580 EFI wont charge battery Arcticcat6 Sled Mods & Tech-Tips 1 01-10-2010 06:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome