2007 650 LCD display not working - ArcticChat.com - Arctic Cat Forum

Utility ATV repair and maintenance & Troubleshooting Place your Utility ATV Repair and Maintenance questions/thoughts here... *not performance*

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 09-19-2011, 09:53 AM Thread Starter
Junior Member
 
Junior Member
Join Date: Sep 2011
Location: Llano
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
2007 650 LCD display not working

I have a 2007 650 and the LCD display does not work. It will start just fine and the backlight works...any ideas??? All fuses appear to be fine...
rbritts is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 09-19-2011, 08:21 PM
Senior Member
 
iamrdman's Avatar
 
Senior Member
Join Date: Jun 2009
Location: st catharines ont
Posts: 209
Thanks: 14
Thanked 15 Times in 15 Posts
ATV: arctic cat 650 trv
2010 Mileage: 600
2009 Mileage: 1500
2008 Mileage: 2500
2007 Mileage: 500
try to disconnect it and plug it back in.this happend to me once
iamrdman is offline  
post #3 of 12 Old 11-07-2012, 02:16 PM
Junior Member
 
Junior Member
Join Date: Nov 2012
Location: Salt Lake
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
! I think the only fix is a new one. cyclepartsnation.com has one for $245 & free shipping. I have 2 machines that they have gone out
alaskalayne is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 11-07-2012, 02:48 PM
Administrator
 
doorfx's Avatar
ArcticChat.com Admin
 
Administrator
Join Date: Jan 2011
Location: calgary ab
Posts: 28,738
Thanks: 2,914
Thanked 2,667 Times in 2,452 Posts
Garage
ATV: 07 500 auto 13 700 XT trv
2010 Mileage: 800
2007 Mileage: 800
2006 Mileage: 800
Make sure you dielectric grease the plug in and make sure the pins are straight and not corroded. Make sure the plug is snug as well.

Dynojet/142m/45p/3rd/3turns--Clipped and drilled--Unifilter--Easy adjust PMS--L.C.V. mod--AC Swaybar--Exhaust mod--2"Snorkels--Sanny shock bushings-- Airdam stage 1--PSC phase 2--21/ 23gr rollers--Dalton yellow spring--.7mm shim--Sanny Steerlites--RTR Flex Bracket--2 up seat / pegs--Tach--AC handguards--28" Outlaw mst's--Skull tailight--Skull shifter--Self Resetting Breakers--1" Wheel spacers--Customcncparts Steering Damper--AC deluxe handwarmers--6000k HID'S hi/lo--AC Deluxe Bumpers--Inline Fuel Filter-- O2 sensor \AFR guage--Black Magic Full Stainless Exhaust System--Wireless Winch Remote--29.5 Outlaws--Fox Podium X Rear Shocks--
2013 700 XT trv eps stock



It's mind over matter,If you don't mind,
It just doesn't matter

No Boost No Bottle
just balls and throttle
doorfx is offline  
post #5 of 12 Old 11-08-2012, 07:26 AM
Senior Member
 
CatCountry's Avatar
 
Senior Member
Join Date: May 2011
Location: Canada
Posts: 340
Thanks: 18
Thanked 30 Times in 30 Posts
Garage
ATV: 05 500 4x4
Get yourself a multimeter and the wiring diagram. Then start checking the inputs (12volts, and grounds). Have fun.
CatCountry is offline  
post #6 of 12 Old 01-24-2013, 02:25 PM
Junior Member
 
scramsay's Avatar
 
Junior Member
Join Date: Jan 2013
Location: Ottawa, Ontario
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
I had the same problem with my 2007 500 LCD, I opened it up to find corrosion on the bottom on the eeprom on the bottom of the board. Using a light brush I took it off to find 5 of the pins had rusted away. There is a hole in the back of the display where water can get and it doesnt seem to be able to get out. My suggestion would be to coat the board in some sort of laquer spray on the board and components to ensure it doesnt rust if moisture does get into the display. Hope this helps you. Mine was easy to take apart and inspect once you get it out of the pod. Four torx screws and you are in.
scramsay is offline  
post #7 of 12 Old 01-24-2013, 06:18 PM
Administrator
 
doorfx's Avatar
ArcticChat.com Admin
 
Administrator
Join Date: Jan 2011
Location: calgary ab
Posts: 28,738
Thanks: 2,914
Thanked 2,667 Times in 2,452 Posts
Garage
ATV: 07 500 auto 13 700 XT trv
2010 Mileage: 800
2007 Mileage: 800
2006 Mileage: 800
Read this thread

http://forum.highlifter.com/How-to-w...-m3893352.aspx

Dynojet/142m/45p/3rd/3turns--Clipped and drilled--Unifilter--Easy adjust PMS--L.C.V. mod--AC Swaybar--Exhaust mod--2"Snorkels--Sanny shock bushings-- Airdam stage 1--PSC phase 2--21/ 23gr rollers--Dalton yellow spring--.7mm shim--Sanny Steerlites--RTR Flex Bracket--2 up seat / pegs--Tach--AC handguards--28" Outlaw mst's--Skull tailight--Skull shifter--Self Resetting Breakers--1" Wheel spacers--Customcncparts Steering Damper--AC deluxe handwarmers--6000k HID'S hi/lo--AC Deluxe Bumpers--Inline Fuel Filter-- O2 sensor \AFR guage--Black Magic Full Stainless Exhaust System--Wireless Winch Remote--29.5 Outlaws--Fox Podium X Rear Shocks--
2013 700 XT trv eps stock



It's mind over matter,If you don't mind,
It just doesn't matter

No Boost No Bottle
just balls and throttle
doorfx is offline  
post #8 of 12 Old 01-25-2013, 02:50 AM
Junior Member
 
scramsay's Avatar
 
Junior Member
Join Date: Jan 2013
Location: Ottawa, Ontario
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Excellent suggestion, this will be done to the new one, Thanks
scramsay is offline  
post #9 of 12 Old 01-25-2013, 07:12 AM
Administrator
 
doorfx's Avatar
ArcticChat.com Admin
 
Administrator
Join Date: Jan 2011
Location: calgary ab
Posts: 28,738
Thanks: 2,914
Thanked 2,667 Times in 2,452 Posts
Garage
ATV: 07 500 auto 13 700 XT trv
2010 Mileage: 800
2007 Mileage: 800
2006 Mileage: 800
If you buy a new one most of them are already done except the hole in the back

Dynojet/142m/45p/3rd/3turns--Clipped and drilled--Unifilter--Easy adjust PMS--L.C.V. mod--AC Swaybar--Exhaust mod--2"Snorkels--Sanny shock bushings-- Airdam stage 1--PSC phase 2--21/ 23gr rollers--Dalton yellow spring--.7mm shim--Sanny Steerlites--RTR Flex Bracket--2 up seat / pegs--Tach--AC handguards--28" Outlaw mst's--Skull tailight--Skull shifter--Self Resetting Breakers--1" Wheel spacers--Customcncparts Steering Damper--AC deluxe handwarmers--6000k HID'S hi/lo--AC Deluxe Bumpers--Inline Fuel Filter-- O2 sensor \AFR guage--Black Magic Full Stainless Exhaust System--Wireless Winch Remote--29.5 Outlaws--Fox Podium X Rear Shocks--
2013 700 XT trv eps stock



It's mind over matter,If you don't mind,
It just doesn't matter

No Boost No Bottle
just balls and throttle
doorfx is offline  
post #10 of 12 Old 01-28-2013, 07:08 AM
Senior Member
 
hav24wheel's Avatar
 
Senior Member
Join Date: Jul 2011
Location: ND
Posts: 934
Thanks: 45
Thanked 39 Times in 39 Posts
ATV: Foreman 500, 400 FIS Auto
Might, just be random unfindable wiring issues like mine has. One time display doesn't work, than it does. Some times shut the key off and can walk 5 steps b4 it shuts off. I figure if it runs and charges the battery, good enough. Lol

Dave

2014 Honda Foreman ES, and PS 30x10x12 Interforce tires no lift.
2007 AC 400 FIS 27s
hav24wheel is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > Utility ATV repair and maintenance & Troubleshooting

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
display not working dirt road scholar General ATV Discussion 5 08-20-2010 09:28 PM
LCD Display not working properly jbthunderbird General ATV Discussion 2 05-20-2010 05:12 AM
are my display lights working correctly? kingofthehill F Chassis 2007- ?? 2 12-08-2009 11:13 AM
Display not working molekatz General ATV Discussion 5 12-05-2008 08:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome