Artic cat 580 EXT problems - ArcticChat.com - Arctic Cat Forum

Sled Mods & Tech-Tips Learn the best tips/tricks from people have done it before.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-30-2010, 04:35 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Nov 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Artic cat 580 EXT problems

Hey guys,

Ok, I have a '94 580 EXT and I'm am having problems with it.

First off it just wasn't running well, It would go good for a while then I would lose all my rpms and would have problems getting the engine revved up past 1000 rps, It would also die if the rpm's got to low and wouldn't be start-able for about 15 min. It then progressed to overheating (even while idling) and a lot of the antifreeze would boil out (It would blow off the hose on top).

I ripped the heads off and the pistons seemed sticky like antifreeze was inside, I checked the seals and gaskets but they looked good (could be bad, i'm no expert)

I friend suggested just taking out the thermostat and also the little o-ring in the head got to hot and is leaking. I also haven't been into the water pump yet but maybe something wrong with that could cause the overheating?

Was hoping to gain a little insight on this so any help you guys could give would be great.

Thanks
Chris

Last edited by Lotto; 11-30-2010 at 04:39 PM.
Lotto is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > General Snowmobile Discussion > Sled Mods & Tech-Tips

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Artic Cat 300 cc Atv running problems earlbear General ATV Discussion 4 02-24-2010 08:55 AM
2004 artic cat 400 4x4 steering problems vanmedic General ATV Discussion 6 10-19-2009 11:06 PM
new to Artic Cat and have problems poorhotrodder Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 7 10-16-2009 10:58 PM
1997 artic cat 580 efi problems busch2palace General Snowmobile Discussion 0 01-23-2009 06:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome