1100 turbo problems - ArcticChat.com - Arctic Cat Forum

PROCROSS XF/ZR 137" 2012 + chassis

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 24 Old 11-27-2011, 05:47 PM Thread Starter
Member
 
SPITFlRE's Avatar
 
Member
Join Date: Nov 2011
Location: Winnipeg Manitoba
Posts: 43
Thanks: 2
Thanked 1 Time in 1 Post
Garage
Sled: XF 1100 turbo SP Limited
1100 turbo problems

Just picked up my new 2012 XF 1100 Turbo SP Limited yesterday and already found a few problems.
First thing i noticed was that it was leaking oil, I could barely see any oil in the chaincase window, the engine oil was overfilled. It has a terrible paint job, you can see the metal right through the white paint on the tunnel. There is already a recall on the reverse.
I thought it would be a lot better when I ordered it.
SPITFlRE is offline  
Sponsored Links
Advertisement
 
post #2 of 24 Old 11-27-2011, 07:29 PM
Member
 
Member
Join Date: Apr 2011
Location: MI
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
Hmm, I thought the a-arms, bumpers, skid, tunnel was powder coated not painted? I haven't heard of an official bulletin for the reverse. I spoke with my dealer last week as mine should be delivered 11/28 and the service manager hasn't received any recalls.
German Hospitality is offline  
post #3 of 24 Old 11-27-2011, 08:35 PM
Member
 
Member
Join Date: Oct 2011
Location: North Dakota
Posts: 99
Thanks: 1
Thanked 1 Time in 1 Post
We just picked up our XF 1100 non-turbo and checked the reverse before driving off the parking lot. Get it home and try and use reverse to back it into the garage and the engine service light goes on and reverse is no longer functional. This was after trailering 7 hours on dry roads (no salt, etc.) as the dealer is a significant distance.
TJ427 is offline  
Sponsored Links
Advertisement
 
post #4 of 24 Old 11-28-2011, 06:28 PM
Team ArcticChat
 
Curless Auto Repair's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Feb 2009
Location: Grand Rapids
Posts: 277
Thanks: 0
Thanked 4 Times in 4 Posts
Sled: 2012 XF1100 Turbo retro
10-11 Mileage: 1700
09-10 Mileage: 1000
08-09 Mileage: 2000
ATV: Honda 450R
There are tech service bulletins on the reverse, hi beam switch, and blow off valve sticking. When I picked my sled up I was told that the service for these was already performed at Cat.
Curless Auto Repair is offline  
post #5 of 24 Old 11-29-2011, 12:41 AM
Senior Member
 
Firecatdude's Avatar
 
Senior Member
Join Date: Feb 2011
Location: N.W.Ontario
Posts: 177
Thanks: 25
Thanked 6 Times in 6 Posts
Sled: 2012 XF 1100 Turbo LXR
10-11 Mileage: 1000
09-10 Mileage: 1500
08-09 Mileage: 1000
07-08 Mileage: 2500
06-07 Mileage: 2700
ATV: 2014 700 LTD
Quote:
Originally Posted by Curless Auto Repair View Post
There are tech service bulletins on the reverse, hi beam switch, and blow off valve sticking. When I picked my sled up I was told that the service for these was already performed at Cat.
Hey Curless, Do you know what the built date was for your sled? Mine had been at the dealership for about three weeks and I haven't had a chance to pick it up. Just wondering if mine got fixed up by Cat before it left the factory.
Firecatdude is offline  
post #6 of 24 Old 11-29-2011, 07:13 AM
Team ArcticChat
 
Curless Auto Repair's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Feb 2009
Location: Grand Rapids
Posts: 277
Thanks: 0
Thanked 4 Times in 4 Posts
Sled: 2012 XF1100 Turbo retro
10-11 Mileage: 1700
09-10 Mileage: 1000
08-09 Mileage: 2000
ATV: Honda 450R
Quote:
Originally Posted by Firecatdude View Post
Hey Curless, Do you know what the built date was for your sled? Mine had been at the dealership for about three weeks and I haven't had a chance to pick it up. Just wondering if mine got fixed up by Cat before it left the factory.

Oct 6th, mine did not get delivered for almost another month!
Curless Auto Repair is offline  
The Following User Says Thank You to Curless Auto Repair For This Useful Post:
Firecatdude (11-30-2011)
post #7 of 24 Old 12-02-2011, 07:24 PM
Junior Member
 
xfturbo's Avatar
 
Junior Member
Join Date: Oct 2011
Location: Iowa
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
My reverse gave me problems at first got the code and stuff. Now have 8 miles on sled and it has worked fine since.
xfturbo is offline  
post #8 of 24 Old 12-02-2011, 09:00 PM Thread Starter
Member
 
SPITFlRE's Avatar
 
Member
Join Date: Nov 2011
Location: Winnipeg Manitoba
Posts: 43
Thanks: 2
Thanked 1 Time in 1 Post
Garage
Sled: XF 1100 turbo SP Limited
Quote:
Originally Posted by TJ427 View Post
We just picked up our XF 1100 non-turbo and checked the reverse before driving off the parking lot. Get it home and try and use reverse to back it into the garage and the engine service light goes on and reverse is no longer functional. This was after trailering 7 hours on dry roads (no salt, etc.) as the dealer is a significant distance.
TJ427 did you let the sled idle down for a bit before putting it in reverse? The dealer told me to do that.
SPITFlRE is offline  
post #9 of 24 Old 12-02-2011, 09:22 PM
Member
 
Member
Join Date: Oct 2011
Location: North Dakota
Posts: 99
Thanks: 1
Thanked 1 Time in 1 Post
SPITFIRE, we allowed it to warm up to appropriate temp per the idiot lights and tried shutting off. Let it cool down, ran track briefly and reverse just gave the service engine light every time we tried. It did work once at the dealer prior to departing without any issues (only tried once). Hope everyone gets their turbo sleds, we are eagerly awaiting ours - latest date is December 12th for delivery.
TJ427 is offline  
post #10 of 24 Old 12-03-2011, 04:50 PM
Junior Member
 
Junior Member
Join Date: Dec 2008
Location: Air Ronge Saskatchewan
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Sled: 2009 F8
08-09 Mileage: 250
07-08 Mileage: 5000
06-07 Mileage: 5000
ATV: Arctic cat 400
2008 Mileage: 1000
2007 Mileage: 500
2006 Mileage: 200
Service bulletin coming about the reverse. Things fall apart in the chaincase when you add oil. My other (new) problem is that the machine is missing and won't start. I've got 13 miles on it. Good f--- start to the season
northjack is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > PROCROSS XF/ZR 137"

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
XF 800 vs. 1100 Turbo CatsandDog PROCROSS XF/ZR 137" 26 01-12-2012 01:49 PM
XF 1100 Turbo 141'' or M1100 Turbo 153" Tiller 4 Strokes 2 11-03-2011 09:18 PM
what to buy 1100 turbo vs 800 kool whipp Procross - Proclimb Chassis General Discussion 65 04-28-2011 01:58 PM
F 1100 Turbo RIsnoPRO83 PROCROSS F/ZR/ElTigre/RR 16 03-13-2011 12:19 PM
1100 turbo secondary clutch problems hprule 4 Strokes 1 01-11-2009 09:31 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome