2013 procross xf 1100 turbo belt problems - Page 2 - ArcticChat.com - Arctic Cat Forum

Procross - Proclimb Chassis General Discussion General talk regarding 2012 & newer

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 Old 02-03-2013, 10:33 AM
Banned
 
Banned
Join Date: Oct 2012
Location: michigan
Posts: 122
Thanks: 12
Thanked 12 Times in 12 Posts
Sled: 2013 XF1100Turbo limited
10-11 Mileage: 2000
09-10 Mileage: 1500
08-09 Mileage: 1000
So i finally got my cross the up snowmobile trip in and gat a chance to really test this sled out everything seems great with the acception of the rear suspension bottoming easily but I think that will be an issue to sort out next summer. Put 970 miles when the first belt blew. We were running down a long straight trail at about 70 mph for probably 30 or 40 miles and the temp was around 28 degrees outside then pop the belt went. Pulled off to the side opened the panel and looked in, the exhaust was cherry red I mean cherry took a few min to cool down. I wouldnt say the clutches were super hot but my guess is that these turbos just build way too much under hood heat and eventually the belt lets go. I did read on another post that some of the sound insulation on the clutch side blocks the main exit slit on the side panel and it does on mine as well. So I guess I am going to trim that out to provide added air flow and I am probably going to pick up some frogskin vents to get even more heat out. they make them for both sides exhaust and clutch on these sleds. The next couple days temp really dropped and I noticed that the sled didnt get nearly as hot as normal under the hood. I think these sleds almost need to operate under about 20 degrees before there happy in stock form. Anyone else have thoughts.
1838doughboy is offline  
Sponsored Links
Advertisement
 
post #12 of 13 Old 02-06-2013, 01:54 PM
Junior Member
 
Kdavsue1's Avatar
 
Junior Member
Join Date: Mar 2011
Location: Watervliet, MI
Posts: 20
Thanks: 5
Thanked 3 Times in 2 Posts
Procross Turbo underhood heat

I rode the UP last week with my 2013 XF1100 Turbo Limited. Went from 28 degrees to 15. I did notice that when we stopped on the trail that the heat was rolling off of my sled while my wife's new NA Crosstour and the two Polaris's that were with us didn't show any visible signs of heat. We were both in break in mode and didn't hammer them at all. Did vary the speed and ran 20 or more miles at 50-60 mph. No issues. Belts on both Cats look like new. I may look into frogskin vents for the clutch side, but so far so good. Also had a 2012 XF1100 Turbo LXR last year that rebounded me off the seat. My Limited with air shocks and Hygear linkage rode very nice.
Kdavsue1 is offline  
post #13 of 13 Old 02-13-2013, 04:04 PM
Banned
 
Banned
Join Date: Oct 2012
Location: michigan
Posts: 122
Thanks: 12
Thanked 12 Times in 12 Posts
Sled: 2013 XF1100Turbo limited
10-11 Mileage: 2000
09-10 Mileage: 1500
08-09 Mileage: 1000
With the hygear linkage did you but the whole kit meaning extra shock resivoir, and you say it rode excellent did you have a chance to ride it before adding it? I guess you could pm me so we dont hijack this thread but I amunimpressed with the rear suspension in stock form.
1838doughboy is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > Procross - Proclimb Chassis General Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 xf 1100 turbo belt problems 1838doughboy New Member Introduction Only!!!! 1 01-20-2013 02:18 PM
2012 xrs to a f procross sp 1100 turbo wildeye12 PROCROSS F/ZR/ElTigre/RR 2 10-21-2012 10:41 AM
F versus XF?? Ordering a 2013 1100 Turbo drewcosta PROCROSS XF/ZR 137" 6 04-16-2012 07:22 PM
1100 turbo problems SPITFlRE PROCROSS XF/ZR 137" 23 01-16-2012 09:27 AM
Procross 1100 turbo service manual/ DVD Tomcat-1 PROCROSS F/ZR/ElTigre/RR 2 11-23-2011 03:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome