New Member Introduction & Site Assistance Introduction Area If you are new to the site please introduce yourself in here. You will find that our community is very friendly. If you have questions on how to use the site this is the place to ask! If you are having difficult starting a new thread in this section, this convenient link should start a new thread for you. Simply Click Here. However this is NOT a how do I fix this or what is wrong thread!!!! please use the correct forums for that.

Reply
Old 10-29-2012, 10:53 PM   #1
Senior Member
 
1838doughboy's Avatar
 
Senior Member
Join Date: Oct 2012
Location: michigan
Thanks: 11
Thanked 9 Times in 9 Posts
Sled: 2013 XF1100Turbo limited
10-11 Mileage: 2000
09-10 Mileage: 1500
08-09 Mileage: 1000
2013 xf 1100 turbo belt problems

last friday I picked up my 2013 xf 1100 turbo and when I got it home I wanted to back it off the trailer so I could mount my GPS on it. While I was backing it off the trailer i noticed belt smell and belt dust "its a white limited so it shows up imediately". Anyway didnt think much of it until i went to put it back on the trailer and it happened again. My question is am I being paranoid because of all last years horror stories or do you think slow speed new carbides biteing into my concrete was the culprit. Talked to a mechanic and he said there could have been some oil on the clutch from shipping and to wipe it off with brake parts cleaner. Any thoughts?
Also I am comeing off a 2010 z1 ext and when i took the secondary off that sled I could just put the center bolt back in and crank the secondary right back open the secondary on this either closes tighter or the center bolt is shorter because if I take it off my 2013 i cant get it back on unless i flip the big washer back around which will open the secondary a 1/4 inch then i can put something in there to keep it open back the screw out flip the washer and install the belt like normal. So is the screw just shorter?
1838doughboy is offline   Reply With Quote
Remove Ads
Old 01-20-2013, 02:18 PM   #2
Junior Member
 
Junior Member
Join Date: Dec 2012
Location: manitoba
Thanks: 0
Thanked 0 Times in 0 Posts
I had the same trouble last night on a cold night trying to chang e a blown belt ,same machine you have 380 miles ,trying to change the belt was brutal
lloydy is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » New User & Site Help Area » New Member Introduction & Site Assistance


Search tags for this page

2013 1100 turbo belt issues

,
2013 arctic cat 1100 turbo belt problems
,

2013 arctic cat 1100 turbo problems

,
2013 arctic cat 1100 turbo reviews
,
2013 arctic cat f1100 problems
,
2013 arctic cat f1100 turbo problems
,
2013 arctic cat problems
,
2013 arctic cat recalls
,
2013 xf 1100 turbo problems
,
arctic cat xf 1100 turbo belt problems blown
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
F versus XF?? Ordering a 2013 1100 Turbo drewcosta PROCROSS XF 6 04-16-2012 07:22 PM
1100 turbo problems SPITFlRE PROCROSS XF 23 01-16-2012 09:27 AM
2012 1100 Turbo belt part # joeee Procross - Proclimb Chassis General Discussion 2 11-14-2011 08:49 AM
XF 1100 Turbo 141'' or M1100 Turbo 153" Tiller 4 Strokes 2 11-03-2011 09:18 PM
1100 turbo secondary clutch problems hprule 4 Strokes 1 01-11-2009 09:31 AM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.