General ATV Discussion Discussion Forum for Arctic Cat ATVs

Reply
Old 09-03-2011, 02:18 PM   #1
Junior Member
 
Junior Member
Join Date: Aug 2011
Location: Missouri
Thanks: 0
Thanked 0 Times in 0 Posts
ATV: 2007 Arctic Cat 650 H1 LE TRV
2010 Mileage: 100
2009 Mileage: 200
LCD Display Problems

Here we go again. I love my atv, 2007 650h1 trv le, but when one thing goes wrong everything goes wrong. I noticed after a recent trip and cleaning that the spedo and guages where not working correctly. They come on, then go off after about 10 seconds. They stay off for about 10 seconds then come back on and act like I have just turned the key on. They stay on for 10 seconds and then the cycle continues until I stop riding. All other electrical componets are woking fine and the machine runs fine. I've checked the fuses and they look good. Tried to check the connection into the spedo, but I couldn't realy get to it. Before I tore the thing apart I figured I would ask to see if anyone else has had this problem. Thanks.
hargrovet is offline   Reply With Quote
Remove Ads
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » ATV's » General ATV Discussion


Search tags for this page

arctic cat 550 lcd problems

,
arctic cat 650 display problems
,

arctic cat atv display problem

,

arctic cat display failure

,

arctic cat display issues

,

arctic cat display problem

,

arctic cat lcd display

,

arctic cat lcd problems

,

arctic cat troubleshooting lcd display

,

artic cat 400 display troubles

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lcd display PURPLERAIL Utility ATV repair and maintenance & Troubleshooting 6 07-04-2011 05:29 PM
08 f-5 display f-5snopro F Chassis ('07-???) 1 01-03-2009 02:32 PM
Display gone bad? Catterman General ATV Discussion 9 10-05-2006 06:34 PM
Display problems badcat650 Utility Performance / Technical info 1 07-10-2006 08:06 AM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.