no power - ArcticChat.com - Arctic Cat Forum

General ATV Discussion Discussion Forum for Arctic Cat ATVs

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-05-2011, 08:09 AM Thread Starter
Junior Member
 
Junior Member
Join Date: Aug 2011
Location: Winchester
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
no power

Hello All,
I just bought a 2007 Arctic Cat 650 H1 4x4 Automatic TBX with 105 miles. I just replaced the battery(guys at the dealership installed) with the recommended stock battery. I left it on the trickle charger all night and have no power. When I unhook the charger and turn the key to the on position the display lights up (sometimes) but when I pull in the front brake lever the display goes blank and the ignition is dead. There is a slight clicking sound but I'm not sure if that has something to do with the brake light coming on. Is there something that may be wired incorrectly or is this a catastrophic electrical ignition problem that will make me regret not buying the polaris? Please help!

thanks,
Matt
mkeefer is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-05-2011, 09:19 AM
Team ArcticChat
 
jgood's Avatar
Team ArcticChat
 
Team ArcticChat
Join Date: Jul 2007
Location: Iowa
Posts: 1,954
Thanks: 10
Thanked 94 Times in 87 Posts
ATV: 2005 Arctic Cat 300
2010 Mileage: 200
2009 Mileage: 350
2008 Mileage: 400
2007 Mileage: 300
2006 Mileage: 200
Being its a stock battery, did the dealer put the acid in the battery before they installed it?

2005 Arctic Cat 300
6K Diamond White H.I.D. headlights
L.E.D. taillight
L.E.D. reverse light
L.E.D. blue strobe lights
L.E.D. 880 strobes in the high beams
L.E.D. turn signals
LE bumpers
American Eagle 3500lb winch
Synthetic winch rope
E3 Spark plug
DJ jet kit
K&N filter
Modified intake
Muffler mod
Custom oil cooler
Oil temp gauge
Volt gauge
Super Start Platinum AGM Battery
SYMTEC heated grips
Custom shift knob
Custom storage tube
High Lifter 2" Lift Kit
Sanny Suspension Bushings
TigerTail Tow System
1" Wheel Spacers
Vision 160 rims with AMS Swamp Fox tires(For Snow Plowing)
Douglas Quatrosport rims with Maxxis Bighorns V 2.0(For All Around Riding)
STI Slasher rims with custom grooved Outlaw M.S.T.s(For Playing In The Mud)
jgood is offline  
post #3 of 3 Old 08-05-2011, 09:46 AM
Super Moderator
 
FirecatV2's Avatar
ArcticChat.com Moderator
 
Super Moderator
Join Date: Oct 2007
Location: Minnesota
Posts: 3,622
Thanks: 129
Thanked 282 Times in 262 Posts
Sled: Plastic Orange
ATV: 05 650 v2 & 09 550H1
A low battery will cause the conditions you describe. Can you check the voltage? Should be in the 12.6 volt range. A new oem battery needs to be filled properly and charged for 8 hours or so with a 1.5 amp charger.

05 650V2 LE, 09 550H1,04 Arctic Cat 50

"Your best teacher is your last mistake"
FirecatV2 is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > General ATV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
More power- Suggestions please/Power commander?> MississippiMudCat Utility Performance / Technical info 6 09-12-2012 09:49 AM
ZRT 800 NO POWER PLEASE HELP sdtrucking General Snowmobile Discussion 5 10-13-2010 02:59 PM
Temp Gauge Install, SnoBunje "Power Cell", GPS Power iambroke Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 9 12-26-2009 01:13 AM
Getting some power out of my F6 jaybear300 Performance/Racing 2 08-18-2008 08:32 AM
More power WrecklessKelly Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 1 01-02-2006 08:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome