Symptoms of a bad stator - ArcticChat.com - Arctic Cat Forum

General ATV Discussion Discussion Forum for Arctic Cat ATVs

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 03-12-2011, 11:13 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Aug 2010
Location: Texas
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Symptoms of a bad stator

Chasing down issues on my 04 250. Replaced the CDI, Volt reg and magneto(coil), due to shorting out my wire harness. It would start right up, but would not rev up past idle. Got to the point where it just would not run at all, still had spark. Figured it was carb related, cleaned carb and one jet was plugged. Put it back together, would start and idle fine, but as soon as I gave gas it would sputter and die. Just curious, what role the stator plays other charging the battery, running accessories? When running the battery showing 14+ volts, so it seems to be putting out voltage. Any ideas.
tex599 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 03-22-2011, 12:29 AM
Junior Member
 
Junior Member
Join Date: Mar 2011
Location: Bonnyville, ab
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
some times there is a safety throttle switch one on throttle and one on carb and when your cable stretches over time they don't contact right and it is just like hitting the kill switch, release the throttle and it will idle great. You can sometimes bypass these safeties by unplugging your ground at coil. but some safety switch's work through your cdi box which means you gotta adjust the cable to work right hope this helps

Last edited by calebshouse; 03-22-2011 at 12:32 AM.
calebshouse is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > ATV's > General ATV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Diagnose these symptoms... ajsparko Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 4 01-26-2011 01:13 PM
What were the symptoms when your CDI box died? Blaine Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 9 01-28-2009 12:35 PM
Reed Valve Symptoms rat448 Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 3 01-27-2009 05:37 PM
broken reed symptoms Stangcrazy Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 2 11-17-2007 03:25 PM
TPS Symptoms???? welch XFR/Firecat/Sabercat 3 02-05-2007 03:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome