General ATV Discussion Discussion Forum for Arctic Cat ATVs

Reply
Old 02-17-2011, 11:36 PM   #1
Junior Member
 
tdraider1's Avatar
 
Junior Member
Join Date: Feb 2011
Location: kentucky
Thanks: 3
Thanked 1 Time in 1 Post
06 650 H1 Digital Dash

My dash went blank (lights up but no readings) after about 100 miles, so I took it in under warranty and they said they had to replace the wiring harness? Now I have only around 250 miles on it and it goes out again. I bought it at Gander Mountain but they quit selling them awhile ago. Finally theres a place here that sells and services them so I take it in and the guy at the service center tells me that he found out that the 05's and 06's had a problem with that when then the battery gets low or dies, and Cat put out a fix but no recall. He is going to check it out and let me know if that is the problem. I was wondering if anybody else has heard of this or had the same problem and knows how to fix it. I would appreciate any info and will post what I find out from the dealer. Thanks.
tdraider1 is offline   Reply With Quote
Remove Ads
Old 02-18-2011, 09:25 AM   #2
Team ArcticChat
 
650Cat's Avatar
Team ArcticChat  
Team ArcticChat
Join Date: Jun 2007
Location: Emporia, Kansas
Thanks: 0
Thanked 1 Time in 1 Post
ATV: 2007 Arctic Cat 650 H1
2008 Mileage: Not nearly enough.
2007 Mileage: 250 +/-
I've had that happen a few times. The fix I found was just unhooking the battery, waiting a few minutes, and hooking it back up. Don't know if it'll work for you but you could give it a shot. For reference, I have an '07 650H1.
__________________
Toys:
1997 Honda Shadow
1995 Chevy Silverado 2500 6.5 Turbo Diesel 4x4 ^-^
2000 Ford F250
1988 Chevy Camaro
1978 El Camino
2007 Arctic Cat 650H1
650Cat is offline   Reply With Quote
Old 02-18-2011, 01:01 PM   #3
Team ArcticChat
 
gymppi's Avatar
Team ArcticChat  
Team ArcticChat
Join Date: Mar 2006
Location: Wisconsin
Thanks: 19
Thanked 45 Times in 44 Posts
ATV: 2010 700i
Try pushing in the harness into the back of the display, make sure that is good and secure. Also make sure all of the wires into the back of the plug on the harness are nice and secure.
gymppi is offline   Reply With Quote
The Following User Says Thank You to gymppi For This Useful Post:
tdraider1 (03-21-2011)
Old 03-21-2011, 08:07 PM   #4
Junior Member
 
tdraider1's Avatar
 
Junior Member
Join Date: Feb 2011
Location: kentucky
Thanks: 3
Thanked 1 Time in 1 Post
I pulled the plug out and messed with the wires and put some grease on on it and put it back on and it works great. I appreciate the info. Thanks!
tdraider1 is offline   Reply With Quote
Old 03-22-2011, 08:49 AM   #5
Team ArcticChat
 
Terry Slaney's Avatar
Team ArcticChat  
Team ArcticChat
Join Date: Aug 2009
Location: Newfoundland, Canada
Thanks: 17
Thanked 164 Times in 157 Posts
ATV: '08 TRV 500
2010 Mileage: 3300 km
2009 Mileage: 3000 km
good work man!
__________________
08 TRV 500
Custom diamond plate storage boxes | Powermadd handguards | Quadrax 2500 lbs winch | Moose Hand/Thumb warmers | Sanny circuit breakers | 26" interco swamplites on stock rims | Yuasa Battery | Sanny A-arm bushings w/ grease fittings | 2" flex lift | Snorkels | Looped crank vent mod | Custom audio setup | Arctic Cat block heater | Engine Ice coolant | Front and rear brush guard bumpers | Battery Tender jr | ///Airdam stage 1 | Speedwerx 42# stall springs | Amsteel Blue synthetic rope | UHMW hawse fairlead | UNI Air filter | Engine Brake Deleted | Xentec 6000k HIDs| 55w Halogen Reverse light | The Whoolie Shop LED's | LED high beam bulbs | Fuel filter | 3/16" Aluminum skid plate | Modded stock exhaust | Dynojet Kit-144 main-42 pilot-Needle on 3rd notch | Ride in springs





Terry Slaney is offline   Reply With Quote
Old 04-07-2011, 02:05 PM   #6
Junior Member
 
Junior Member
Join Date: Apr 2011
Location: memphis TN.
Thanks: 0
Thanked 0 Times in 0 Posts
no gauges. working

I've got the same problem on my 2007 650 h1 seems like it should be a recall or post how to solve the problem. If I find out how to fix it I will let you know. I still think arctic cat should do tthe right thing.because I hear too many are having the same problem.
Bobby s is offline   Reply With Quote
Old 04-07-2011, 02:38 PM   #7
Team ArcticChat
 
Savageman69's Avatar
Team ArcticChat  
Team ArcticChat
Join Date: Mar 2007
Location: Exeter, Ontario, Canada
Thanks: 5
Thanked 385 Times in 366 Posts
Sled: 2014 ZR 7000 LIMITED
ATV: 2007 Arctic Cat 700 EFI
remove the battery cables from the battery and touch them together it will reset the poid and it will most likely come back to life. Ive never had to replace mine
__________________
-------------------
Mark


2014 Arctic Cat ZR 7000 Limited
Float Guards - RaceWerx Quick Seat Kit - Battery Tender Hook Up - Hids
2007 Arctic Cat 700 EFI
LE Rims - Warn 3000lb - Full Snorkels - Rad Relocation - Uni Air Filter - 16 Gram Rollers - 1 mm Primary Shim - EPI Lime Green Secondary Spring - 2.5mm Machined Primary - M109R Injector - VDI Copperhead Ecu - Odyssey PC680 - Bedlined Bumpers & Racks - M109R Motor Mounts - Upper Bump Stop Mod - Skull Shifter - Led Tail Light - 6k hid & led hi - Engine Ice - Heat Shielded Side Panels - Iridium plug - Sanny Steerlite Full Bushings - Sanny Shock Bushings - Foot Brake Delete - 4x 1200lm led floods - 1x Rigid Sr led 6inch Bar - Mudpro Shocks and Springs - ODI Grips - Looped Crank Case Vent/Fuel Tank/Rad Overflow - Sealed Cluster -B&J Custom Exhaust(3inch Outlet) - Front/Rear Mp1000 Axles - RDC Billet Rear Diff Cover - Camoplast tatou 4s Tracks - Rad Cap Temp Gauge - Volt Gauge - Symtec Heated Grips & Boot Warmers - Inline Fuel Filter - A-Arm & Hub Grease Mod - Fender Extensions - Handlebar Mitts - Orange Shock Covers - Front Drive Shaft Loop - 1.5 Lift - Highlifter Arched Tie Rods - ????? / No Limit Venom Rims - LE Pod/LE Plastics - D&D Billet Gas Cap - Nology Profire Coil/Wire & Cap - Orange Billet Brake Res Cover - TigerTail Tow System - 28 zillas / Itp System 6 Rims - Rear Diff Brace
Savageman69 is offline   Reply With Quote
Old 04-07-2011, 08:11 PM   #8
Senior Member
 
Senior Member
Join Date: Sep 2005
Location: Base of the Rocky Mountains
Thanks: 91
Thanked 486 Times in 413 Posts
ATV: ThunderLemon 1000
2008 Mileage: Depends upon Fa
Quite often the POD display will go blank when a person jumps starts the ATV from a running automobile. It can also happen if the battery cables are loose or corroded. Or if the voltage regulator is going bad, or a bad frame ground. It's a protection circuit that is activated to protect the electronics in the display from over voltage. And of course it could be a loose or corroded connection on the bottom of the display too.

99% of the time you can reset using the method savageman69 recommended.
__________________
Have a Problem?

Troubleshooting First Steps, An amazing number of problems are cured with just these two items.

1. Make sure your battery is FULLY Charged.
2. Try a new spark plug.

Search threads, Check Pinned Section. Pinned Topics Manual or wiring diagram? Manuals
http://countrycat.com/ccstore/index...._Diagrams.html

Improving Search.

Better results when searching for specific information. To find threads where ALL the words, instead of ANY of the words "650H1, Carb, Jetting, Needle Jet, Snorkel" were found...Open up a search window in www.google.com In the find box type without the quotes "650H1 Carb Jetting Needle Jet Snorkel site:Arcticchat.com" & Press return. Find threads, replies or topics by a specific member; just by inserting their user name into the search list; Chances are, your problem is NOT unique and it has been solved many times before.

Are you in a hurry to get an answer?
Use the Google Search Tip
Wyo_H1_Cat is offline   Reply With Quote
The Following 2 Users Say Thank You to Wyo_H1_Cat For This Useful Post:
catsneyes (10-07-2011), weaselcreek (04-07-2011)
Old 03-02-2012, 04:26 AM   #9
Junior Member
 
Junior Member
Join Date: Mar 2012
Location: illinois
Thanks: 0
Thanked 0 Times in 0 Posts
06 arctic cat 650 h1

i have a 06 arctic cat 650h1 my dash display is resetting ive checked and i have 2 powers to the display. ive unhooked the battery and charged, ive touched positive and negative together hooked back up and still resetting. ive greased the connector with die electric, repaired all damaged wiring in the column, checked all cdi boxes under seat and above fuel tank, when first resetting with display functioning like it should gets to half tank of fuel then resets, tried new pod and still does it. checked harness for any other problems but all looks ok. pulling my hair out over this please help thanks anthony.
anthonyg2500 is offline   Reply With Quote
Old 03-02-2012, 08:31 AM   #10
Administrator
 
doorfx's Avatar
ArcticChat.com Admin  
Administrator
Join Date: Jan 2011
Location: calgary ab
Thanks: 1,178
Thanked 1,401 Times in 1,296 Posts
ATV: 07 500 auto 13 700 XT trv
2010 Mileage: 800
2007 Mileage: 800
2006 Mileage: 800
If it is just the fuel gauge run a couple tanks through it with an additive called STARTRON it's the sending unit in the tank. This will clean it right up and keep using it
__________________
Dynojet/142m/45p/3rd/3turns--Clipped and drilled--Unifilter--Easy adjust PMS--L.C.V. mod--AC Swaybar--Exhaust mod--2"Snorkels--Sanny shock bushings-- Airdam stage 1--PSC phase 2--21/ 23gr rollers--Dalton yellow spring--.7mm shim--Sanny Steerlites--RTR Flex Bracket--2 up seat / pegs--Tach--AC handguards--28" Outlaw mst's--Skull tailight--Skull shifter--Self Resetting Breakers--1" Wheel spacers--Customcncparts Steering Damper--AC deluxe handwarmers--6000k HID'S hi/lo--AC Deluxe Bumpers--Inline Fuel Filter-- O2 sensor \AFR guage--Black Magic Full Stainless Exhaust System--Wireless Winch Remote--29.5 Outlaws--Fox Podium X Rear Shocks--
2013 700 XT trv eps stock



It's mind over matter,If you don't mind,
It just doesn't matter

No Boost No Bottle
just balls and throttle
doorfx is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » ATV's » General ATV Discussion


Search tags for this page
06 arctic cat 500 atv display will not work no matter what
,

2007 arctic cat 650

,
2011 450 arctic cat has no dash and wont start
,
2011 articat 700 dash pod
,
650h1 arctic cat prowler dash
,

arctic cat atv digital display problems

,

how to clear odometer err kingquad

,

how to take a dash pod off arcticat atv

,

putting a voliage regulator on a artic cat 650 h1

,
where is the speedometer head located on 2007 trv
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Digital Dash differences ? Adam B. Utility Performance / Technical info 2 09-16-2008 08:40 PM
digital dash P Woolf Prowler 9 02-11-2008 12:19 PM
M7 dash bag Snowmark M Series/Mtn. 1 10-27-2004 09:43 AM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.