F1000 Gauge Problem - ArcticChat.com - Arctic Cat Forum

F Chassis 2007- ?? Also known as the Twin Spar chassis.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 02-09-2012, 12:09 PM Thread Starter
Senior Member
 
Senior Member
Join Date: Dec 2007
Location: Erie, PA
Posts: 153
Thanks: 2
Thanked 2 Times in 2 Posts
Sled: '07 F5LXR, '08 F1000
10-11 Mileage: 2000
09-10 Mileage: 1500
08-09 Mileage: 1200
07-08 Mileage: 500
06-07 Mileage: 500
F1000 Gauge Problem

I just returned from Canada with my first ride on my new 2008 F1000. I was hoping for the best since the sled only had 15 miles on it when we left, but managed 750 miles this past weekend. I did have one problem with the machine though - the speedo would intermittantly work (both digital and analog would show 0) even though the odometers were clicking away. If I shut off the sled and restarted it, the speedo then seemed to work for a while again, but sometimes would come and go. Also, when the high beams were turned on, it would cauase the gauges to reset and the speedo would stop working. The last night the sled was parked outside at about -10F. The next morning, the sled started fine, except the entire display was hosed with random segments lighting on the display (standard gauge). It took about 90 minutes of riding before the gauge read correctly again. I did have the moisture recall done before it ever hit the trail, but does this sound like a bad gauge, wiring, or a common problem on the F10's? Other than that, the sled ran good except for a little weak above 85 I thought (used to the thudercat). Thanks!
behrend is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 02-10-2012, 08:04 PM
Senior Member
 
firecat5's Avatar
 
Senior Member
Join Date: Apr 2006
Location: Rochester, NY
Posts: 226
Thanks: 4
Thanked 20 Times in 20 Posts
Sled: 2004 Firecat F-7 EFI 2008 F1000 2003 440
10-11 Mileage: 638
09-10 Mileage: 700
08-09 Mileage: 740
07-08 Mileage: 320
06-07 Mileage: 680
Someone had a thread going here for a problem with the High/Low Beam switch and Gauge Pod problem. I can't remember what it was titled, or when it was though. I know the moisture problem existed on the 2008 F sleds. Mine was never done until now, (last month), even though the sled was a leftover when i bought it new in Feb. of 2011.Mine acted up when i was riding it in some rain last winter. The fuel gauge would go from full to empty intermittenly.

Last edited by firecat5; 02-10-2012 at 08:07 PM. Reason: added info.
firecat5 is offline  
post #3 of 12 Old 02-12-2012, 06:05 AM
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Posts: 4,157
Thanks: 21
Thanked 317 Times in 298 Posts
Super common, AC replaced mine twice before figuring out it was a harness problem.
zr sled head is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 02-12-2012, 08:56 PM
Senior Member
 
firecat5's Avatar
 
Senior Member
Join Date: Apr 2006
Location: Rochester, NY
Posts: 226
Thanks: 4
Thanked 20 Times in 20 Posts
Sled: 2004 Firecat F-7 EFI 2008 F1000 2003 440
10-11 Mileage: 638
09-10 Mileage: 700
08-09 Mileage: 740
07-08 Mileage: 320
06-07 Mileage: 680
Was it for a fuel gauge problem, or worse ? My clock doesn't seem to be accurate, and now the fuel gauge doesn't stay on the top bar after I fill the tank, sometimes it will for a mile or two. So far, after 400 miles total on the sled those are the only problems. The hood fits (shuts) like crap.Do you know what harness they replaced ?

Last edited by firecat5; 02-12-2012 at 08:57 PM. Reason: additional info.
firecat5 is offline  
post #5 of 12 Old 02-12-2012, 09:30 PM
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Posts: 4,157
Thanks: 21
Thanked 317 Times in 298 Posts
-gas gauge, yours and pretty much everyone elses
-clock, set mine once, out by hours now
-hood, yours and most of the others out there
they replaced the dash harness, fixed the problem
zr sled head is offline  
post #6 of 12 Old 02-13-2012, 09:05 AM
Senior Member
 
breeze400's Avatar
 
Senior Member
Join Date: Dec 2011
Location: Alden NY
Posts: 292
Thanks: 14
Thanked 9 Times in 9 Posts
Garage
Sled: 2007 F-1000
Heck I was out yesterday with my son and A freind. They both have F7s I have my f1000. All of us were showing 1/2 tank. F7s have guages in the tank, manuel gauges. So we stoped and filled up. Freind and I took 2.6 gal. My son took 2.7. So I guess they are inhairently off a bit.
breeze400 is offline  
post #7 of 12 Old 02-13-2012, 08:14 PM
Junior Member
 
dwinchenabch3's Avatar
 
Junior Member
Join Date: Feb 2012
Location: houlton maine
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
my f1000 does the same thing, ill fill the tank to ware the gas is to the very top of the tank but after 5 minutes of running it says im down however much one of the bars on the elec. readout is.
dwinchenabch3 is offline  
post #8 of 12 Old 02-14-2012, 09:14 AM Thread Starter
Senior Member
 
Senior Member
Join Date: Dec 2007
Location: Erie, PA
Posts: 153
Thanks: 2
Thanked 2 Times in 2 Posts
Sled: '07 F5LXR, '08 F1000
10-11 Mileage: 2000
09-10 Mileage: 1500
08-09 Mileage: 1200
07-08 Mileage: 500
06-07 Mileage: 500
ZR Sled Head - Did you have the speedo and high/low beam problem as well?
behrend is offline  
post #9 of 12 Old 02-14-2012, 12:20 PM
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Posts: 4,157
Thanks: 21
Thanked 317 Times in 298 Posts
My '08 had the exact same problem.
zr sled head is offline  
post #10 of 12 Old 02-14-2012, 08:31 PM
Senior Member
 
firecat5's Avatar
 
Senior Member
Join Date: Apr 2006
Location: Rochester, NY
Posts: 226
Thanks: 4
Thanked 20 Times in 20 Posts
Sled: 2004 Firecat F-7 EFI 2008 F1000 2003 440
10-11 Mileage: 638
09-10 Mileage: 700
08-09 Mileage: 740
07-08 Mileage: 320
06-07 Mileage: 680
Haven't noticed a High/Low Beam Speedo problem on mine...............yet. Hope its not affected like some are.
firecat5 is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > F Chassis 2007- ??

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel Gauge 07 f1000 quit FirecatAB F Chassis 2007- ?? 4 01-28-2012 12:16 AM
gauge problem jwsteward Utility Performance / Technical info 3 08-17-2010 03:10 PM
Fuel gauge problem Randysf6 XFR/Firecat/Sabercat 0 01-27-2009 06:41 PM
m8 snopro gauge problem elk M Series/Mtn. 1 12-17-2007 10:35 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome