08 F1000 coolant/temp light - ArcticChat.com - Arctic Cat Forum

F Chassis 2007- ?? Also known as the Twin Spar chassis.

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 12-21-2010, 07:05 PM Thread Starter
Junior Member
 
Junior Member
Join Date: Sep 2010
Location: London, ON
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
08 F1000 coolant/temp light

Went for a ride a few days ago and the temp light came on, check coolant and it looked low so added some. Few days later it did the same thing, coolant looked low again so added more. Checked for leaks, nothing. Sled isn't smoking/burning and no lose of power. Ideas?
dieselsc is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 12-21-2010, 08:20 PM
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Posts: 4,157
Thanks: 21
Thanked 317 Times in 298 Posts
Your gonna need to take a much closer look for tell tale signs of a leak. Buddy had the same issue, turned out to be a missed smear of silicone between the lower case halves over by the recoil. Also check the heat exchangers for any sign of damage / coolant staining.
zr sled head is offline  
post #3 of 8 Old 12-22-2010, 07:38 AM
Senior Member
 
Senior Member
Join Date: Dec 2003
Location: New Brunswick
Posts: 258
Thanks: 3
Thanked 4 Times in 4 Posts
Sled: 2013 xf1100 turbo
10-11 Mileage: 900
09-10 Mileage: 900
08-09 Mileage: 1800
07-08 Mileage: 1200
ATV: 08 700H1 EFI SE
2010 Mileage: 500
Is there lots of loose snow where you are? If your not getting enough lubrication from the snow it will heat and the light will come on. Just a thought.
JamieZRT is offline  
Sponsored Links
Advertisement
 
post #4 of 8 Old 12-22-2010, 08:10 AM
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Posts: 4,157
Thanks: 21
Thanked 317 Times in 298 Posts
check coolant and it looked low so added some. Few days later it did the same thing, coolant looked low again so added more.
zr sled head is offline  
post #5 of 8 Old 12-23-2010, 12:07 AM
Senior Member
 
Senior Member
Join Date: Dec 2003
Location: New Brunswick
Posts: 258
Thanks: 3
Thanked 4 Times in 4 Posts
Sled: 2013 xf1100 turbo
10-11 Mileage: 900
09-10 Mileage: 900
08-09 Mileage: 1800
07-08 Mileage: 1200
ATV: 08 700H1 EFI SE
2010 Mileage: 500
If the light came on it may have puked some out the over flow tube (over heated), hence why he had to add some coolant..........?
JamieZRT is offline  
post #6 of 8 Old 12-23-2010, 05:49 AM
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Posts: 4,157
Thanks: 21
Thanked 317 Times in 298 Posts
Sorry should have better explained, I thought the same thing but checked his location (London Ontario), they've been socked with several feet of snow over the last few weeks, should not be a low snow issue.
I will however ad, if cruised in the mid range the F10 runs extremely lean / smoking hot, if the light comes on under those conditions, burp the throttle a few times, egt temps immediately drop, temp light goes back out. Never happened with my '08 but was a reg issue with my '07.
Until I added egt gauges had always assumed it was solely a coolant temp issue.
zr sled head is offline  
post #7 of 8 Old 12-23-2010, 07:56 AM Thread Starter
Junior Member
 
Junior Member
Join Date: Sep 2010
Location: London, ON
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks guys. ZR head, that kind of makes sense as my Boondocker is set up for mid range power, will monitor the next couple rides.
dieselsc is offline  
post #8 of 8 Old 12-24-2010, 01:29 AM
Member
 
Member
Join Date: Aug 2008
Location: manitoba
Posts: 98
Thanks: 0
Thanked 4 Times in 4 Posts
Sled: 12 F1100T retro 07 Jag Z1
10-11 Mileage: 1800
09-10 Mileage: 750
08-09 Mileage: 1200
07-08 Mileage: 1000
06-07 Mileage: 1000
If you have access to a cooling system pressure tester hook it up overnight on a cold engine with 13-14 PSI in the sytem, check in the morning to see if you still have the same pressure, if it's bleeding out somewhere you're loosing antifreeze someplace, then look for a coolant leak, this is a good place to start anyway.....some of these little gremlins can drive you crazy....if you loose pressure and no sign of leakage then it's gets interesting......good luck.....
kash is offline  
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > F Chassis 2007- ??

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Temp light DEADhead 4 Strokes 6 02-25-2010 10:56 AM
Exhaust temp/coolant temp sensors Iron Will Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 2 11-10-2005 10:55 AM
coolant temp light RedCatLady XFR/Firecat/Sabercat 11 02-17-2005 07:42 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome