F Chassis ('07-???) Also known as the Twin Spar chassis.

Reply
Old 12-21-2010, 07:05 PM   #1
Junior Member
 
Junior Member
Join Date: Sep 2010
Location: London, ON
Thanks: 0
Thanked 0 Times in 0 Posts
08 F1000 coolant/temp light

Went for a ride a few days ago and the temp light came on, check coolant and it looked low so added some. Few days later it did the same thing, coolant looked low again so added more. Checked for leaks, nothing. Sled isn't smoking/burning and no lose of power. Ideas?
dieselsc is offline   Reply With Quote
Remove Ads
Old 12-21-2010, 08:20 PM   #2
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Thanks: 21
Thanked 311 Times in 294 Posts
Your gonna need to take a much closer look for tell tale signs of a leak. Buddy had the same issue, turned out to be a missed smear of silicone between the lower case halves over by the recoil. Also check the heat exchangers for any sign of damage / coolant staining.
zr sled head is offline   Reply With Quote
Old 12-22-2010, 07:38 AM   #3
Senior Member
 
Senior Member
Join Date: Dec 2003
Location: New Brunswick
Thanks: 3
Thanked 4 Times in 4 Posts
Sled: 2007 F 1000
10-11 Mileage: 900
09-10 Mileage: 900
08-09 Mileage: 1800
07-08 Mileage: 1200
ATV: 08 700H1 EFI SE
2010 Mileage: 500
Is there lots of loose snow where you are? If your not getting enough lubrication from the snow it will heat and the light will come on. Just a thought.
JamieZRT is offline   Reply With Quote
Old 12-22-2010, 08:10 AM   #4
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Thanks: 21
Thanked 311 Times in 294 Posts
check coolant and it looked low so added some. Few days later it did the same thing, coolant looked low again so added more.
zr sled head is offline   Reply With Quote
Old 12-23-2010, 12:07 AM   #5
Senior Member
 
Senior Member
Join Date: Dec 2003
Location: New Brunswick
Thanks: 3
Thanked 4 Times in 4 Posts
Sled: 2007 F 1000
10-11 Mileage: 900
09-10 Mileage: 900
08-09 Mileage: 1800
07-08 Mileage: 1200
ATV: 08 700H1 EFI SE
2010 Mileage: 500
If the light came on it may have puked some out the over flow tube (over heated), hence why he had to add some coolant..........?
JamieZRT is offline   Reply With Quote
Old 12-23-2010, 05:49 AM   #6
Senior Member
 
Senior Member
Join Date: Oct 2003
Location: Earch
Thanks: 21
Thanked 311 Times in 294 Posts
Sorry should have better explained, I thought the same thing but checked his location (London Ontario), they've been socked with several feet of snow over the last few weeks, should not be a low snow issue.
I will however ad, if cruised in the mid range the F10 runs extremely lean / smoking hot, if the light comes on under those conditions, burp the throttle a few times, egt temps immediately drop, temp light goes back out. Never happened with my '08 but was a reg issue with my '07.
Until I added egt gauges had always assumed it was solely a coolant temp issue.
zr sled head is offline   Reply With Quote
Old 12-23-2010, 07:56 AM   #7
Junior Member
 
Junior Member
Join Date: Sep 2010
Location: London, ON
Thanks: 0
Thanked 0 Times in 0 Posts
Thanks guys. ZR head, that kind of makes sense as my Boondocker is set up for mid range power, will monitor the next couple rides.
dieselsc is offline   Reply With Quote
Old 12-24-2010, 01:29 AM   #8
Member
 
Member
Join Date: Aug 2008
Location: manitoba
Thanks: 0
Thanked 4 Times in 4 Posts
Sled: 12 F1100T retro 07 Jag Z1
10-11 Mileage: 1800
09-10 Mileage: 750
08-09 Mileage: 1200
07-08 Mileage: 1000
06-07 Mileage: 1000
If you have access to a cooling system pressure tester hook it up overnight on a cold engine with 13-14 PSI in the sytem, check in the morning to see if you still have the same pressure, if it's bleeding out somewhere you're loosing antifreeze someplace, then look for a coolant leak, this is a good place to start anyway.....some of these little gremlins can drive you crazy....if you loose pressure and no sign of leakage then it's gets interesting......good luck.....
kash is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » F Chassis ('07-???)


Search tags for this page

2007 arctic cat f1000 coolant

,
2007 artic cat f 1000 temp light blinks on an off
,

2007 f1000 sno pro coolant temp sensor location

,

2008 arctic cat f1000 coolant filling

,

arctic cat f1000 coolant temperature sencor

,

arctic cat f1000 cooling

,

arctic cat f1000 overheating

,

f1000 egt

,
f1000 filling cooling system
,

f1000 temp light

Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant Temp light DEADhead 4 Strokes 6 02-25-2010 10:56 AM
Exhaust temp/coolant temp sensors Iron Will Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 2 11-10-2005 10:55 AM
coolant temp light RedCatLady XFR/Firecat/Sabercat 11 02-17-2005 07:42 PM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.