Reply
Old 07-14-2011, 11:01 AM   #1
Junior Member
 
Junior Member
Join Date: Jul 2011
Location: ohio
Thanks: 0
Thanked 0 Times in 0 Posts
2006 clutch problem

i replaced my clutch and a clutch cable. after attaching the cable at the motor i noticed there is not tension on the clutch arm. it just moves either way but doesnt spring back like most other clutches ive encountered. could i have broke or not reassembled correctly? any pointers would be great. thanks!
matthorvat is offline   Reply With Quote
Remove Ads
Old 07-14-2011, 11:01 AM   #2
Junior Member
 
Junior Member
Join Date: Jul 2011
Location: ohio
Thanks: 0
Thanked 0 Times in 0 Posts
it is a dvx 400 by the way.
matthorvat is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » ATV's » DVX/LTZ400/KFX400


Search tags for this page
09 z400 clutch not working
,
2006 arctic cat 400 clutch adjustment
,
adjusting clutch on a 2006 kawi kfx400
,
adjusting clutch on kfx
,

arctic cat dvx 400 clutch problem

,
clutch wont disengage on 2006 arctic cat m7
,
kfx400 clutch adjustment
,
kfx400 clutch problems
,
kfx400 clutch slipping
,
suzuki ltz 400 clutch adjustment
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 500 ATV 4WD problem whtmule General ATV Discussion 3 04-06-2011 04:46 PM
2006 ecu problem asham1 F Chassis ('07-???) 0 02-21-2011 03:39 PM
2006 M7 problem? leadfoot33 M Series/Mtn. 18 01-17-2011 08:22 PM
2006 400 FIS Auto 4 wd problem paravenj General ATV Discussion 3 02-09-2010 10:56 AM
Big problem with my 2006 500 Catzr600 General ATV Discussion 21 03-11-2009 07:36 PM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.