ZX1 LTX laid it on it's side - help - ArcticChat.com - Arctic Cat Forum

Bearcat / Utility Sharing info on your 2 or 4 stroke

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-12-2017, 06:21 AM Thread Starter
Junior Member
 
Junior Member
Join Date: Feb 2017
Location: Minnesota
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
ZX1 LTX laid it on it's side - help

Not a Bearcat but a close cousin, same engine, etc. Well while barely moving it got laid on its side and stopped running. Righted the machine and the engine turns over but no electronics light and it doesn't start. I disconnected the battery for 20 seconds but didn't help. Is there a tilt switch or some other switch that needs to be reset?
The snowmobile is WAY back on the trail, dragging/pulling it out will be major undertaking. HELP
Didn't find anything helpful in the manual.
Thunderrick is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum > Snowmobiles > Arctic Cat Snowmobiles > Bearcat / Utility

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ArcticChat.com - Arctic Cat Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZX1 LTX laid it on it's side - help Thunderrick Z/ZL/ZR/ZRT/Tcat/EXT/jag/cougar 3 02-12-2017 12:21 PM
98 Panther 440 Fan Side Flooding and Going thru Plugs Very Quick Krayjack General Snowmobile Discussion 8 02-11-2017 04:25 PM
04 F6 misfire on PTO side cyl. AquaAndy XFR/Firecat/Sabercat 2 01-12-2017 04:05 PM
Exhaust side flooding dal M Series/Mtn. 0 02-06-2016 05:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome