4 Strokes Z1 Turbo / Z1 / T660

Reply
Old 02-05-2011, 04:05 PM   #1
Junior Member
 
Junior Member
Join Date: Jan 2011
Location: Richmond, Maine
Thanks: 2
Thanked 1 Time in 1 Post
Sled: 2011 TZ1/LXR
10-11 Mileage: 950
09-10 Mileage: 400
08-09 Mileage: 400
Question 2011 tz1/lxr ecu 25

When I press the reverse button a little wrench shows up on the display and ECU 25 scrolls across the display. Reverse stopped working and the backup beeper does not come on. Awful heavy sled to turn around by hand....

I have about 200 miles on it and it worked 4 or 5 times today before it stopped working.

Turning the ignition off and restarting makes the code go away but it reappears when I try to use reverse.

Any help on this before it goes back to the dealer?
chasd60 is offline   Reply With Quote
Remove Ads
Old 02-05-2011, 08:40 PM   #2
Senior Member
 
Senior Member
Join Date: Jan 2009
Location: Orrington,Maine
Thanks: 0
Thanked 33 Times in 31 Posts
Sled: 2011 TZ1 Turbo LXR
10-11 Mileage: 2500
09-10 Mileage: 1500
08-09 Mileage: 3500
07-08 Mileage: 1500
06-07 Mileage: 1500
Had the same code a couple days ago with .4 miles on the new sled. I had to winch the brand new sled onto the trailer and take to the dealer.

Dealer up here jumped on it and less than two hours later found a faulty reverse gear actuator. Replaced it and had us back on the trail that morning.
Baydog is online now   Reply With Quote
The Following User Says Thank You to Baydog For This Useful Post:
chasd60 (02-07-2011)
Old 02-09-2011, 05:25 AM   #3
Junior Member
 
Junior Member
Join Date: Jan 2011
Location: Richmond, Maine
Thanks: 2
Thanked 1 Time in 1 Post
Sled: 2011 TZ1/LXR
10-11 Mileage: 950
09-10 Mileage: 400
08-09 Mileage: 400
Back at the dealer to get the reverse problem fixed and also a Sport Bumper added.
chasd60 is offline   Reply With Quote
Old 02-10-2011, 06:47 AM   #4
Senior Member
 
Senior Member
Join Date: Jan 2009
Location: Orrington,Maine
Thanks: 0
Thanked 33 Times in 31 Posts
Sled: 2011 TZ1 Turbo LXR
10-11 Mileage: 2500
09-10 Mileage: 1500
08-09 Mileage: 3500
07-08 Mileage: 1500
06-07 Mileage: 1500
I was thinking of putting a sport bumper on mine. Any chance you might post a pic when you get it back?
Baydog is online now   Reply With Quote
Old 02-10-2011, 08:58 PM   #5
Junior Member
 
Junior Member
Join Date: Jan 2011
Location: Richmond, Maine
Thanks: 2
Thanked 1 Time in 1 Post
Sled: 2011 TZ1/LXR
10-11 Mileage: 950
09-10 Mileage: 400
08-09 Mileage: 400
 Quote: Originally Posted by Baydog View Post
I was thinking of putting a sport bumper on mine. Any chance you might post a pic when you get it back?
Yes I will.

I will be riding from Augusta to north of Rockwood in a couple of weeks, should be a good ride with the sled on the ITS trails.
chasd60 is offline   Reply With Quote
Reply

Lower Navigation
Go Back   ArcticChat.com - Arctic Cat Forum » Snowmobiles » Arctic Cat Snowmobiles » 4 Strokes


Search tags for this page
arctic cat code 25
,
arctic cat code ecu 25
,

arctic cat ecu 25

,
arctic cat ecu code 25
,
arctic cat ecu25
,
arctic cat tz1 ecu25
,
artic cat ecu 25
,
ecu 25
,

ecu 25 arctic cat

,
tz1 ecu 25
Click on a term to search our sites for related topics.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 CFR F8green XFR/Firecat/Sabercat 3 05-11-2010 09:41 AM
2011 SNO PRO 800 H.O. Nellyf6 SnoPro Chassis 2010+ 12 04-12-2010 08:39 PM
2011 HAMMERMAN SnoPro Chassis 2010+ 15 03-22-2010 10:37 PM
2011 WOW!! AFTAUCATMAN General Snowmobile Discussion 22 03-07-2010 06:12 PM


Garage Plus vBulletin Plugins by Drive Thru Online, Inc.